Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#11368 closed defect (fixed)

No comments in mail

Reported by: regis.patroix@… Owned by: Jun Omae
Priority: normal Component: TracHtmlNotificationPlugin
Severity: normal Keywords:
Cc: regis.patroix@… Trac Release: 0.12

Description

Hi,

Comments are not visible in the email, but they are present in the source.

Best regards.

Attachments (6)

trac_html.png (34.9 KB) - added by regis.patroix@… 4 years ago.
no_comments.txt (27.4 KB) - added by regis.patroix@… 4 years ago.
SELECT * FROM ticket WHERE id=18.csv (385 bytes) - added by regis.patroix@… 4 years ago.
SELECT * FROM ticket_custom WHERE ticket=18 ORDER BY name.csv (124 bytes) - added by regis.patroix@… 4 years ago.
SELECT * FROM ticket_change WHERE ticket=18 ORDER BY time, field.csv (1.3 KB) - added by regis.patroix@… 4 years ago.
htmlmail-1390834904.png (23.6 KB) - added by Jun Omae 4 years ago.

Download all attachments as: .zip

Change History (24)

Changed 4 years ago by regis.patroix@…

Attachment: trac_html.png added

Changed 4 years ago by regis.patroix@…

Attachment: no_comments.txt added

comment:1 Changed 4 years ago by Jun Omae

It cannot be reproduced to me. Could you please post how to reproduce? If you cannot reproduce, post the result of the following queries, instead.

SELECT * FROM ticket WHERE id=18;
SELECT * FROM ticket_custom WHERE ticket=18 ORDER BY name;
SELECT * FROM ticket_change WHERE ticket=18 ORDER BY time, field

comment:2 Changed 4 years ago by Jun Omae

Keywords: needinfo added

Changed 4 years ago by regis.patroix@…

Changed 4 years ago by regis.patroix@…

comment:3 Changed 4 years ago by lukasz.matecki@…

I also cannot see the comments (the ticket header is OK but no comments are present). I'm using Trac 1.1.1.

comment:4 Changed 4 years ago by Jun Omae

It works for me. Please post your environment information and how to reproduce it on any environments.

comment:5 Changed 4 years ago by anonymous

I'm not sure what kind of environment information would you like me to provide, I'm pasting what my !admin panel shows: Trac 1.1.1 trachtmlnotificationplugin 0.12.0.1

I have ticket updates through commit messages enabled (don't remember the name of extension).

I've took a look at the email source and the comment is present in the text/plain section:

--===============1732353417==
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 8bit

#8: Generatory przebiegów realizowane programowo
--------------------------------------+-----------------------------------
  Reporter:  Lukasz                   |      Owner:  Lukasz
      Type:  task                     |     Status:  new
  Priority:  minor                    |  Milestone:  VTB-1425_PCU prototyp
 Component:  MATES-DIO3-MK1 firmware  |    Version:  0.9 - prototypy MK1
Resolution:                           |   Keywords:
--------------------------------------+-----------------------------------
\
\
\
\
\
\

Comment (by Lukasz):

 Chyba dopiero w MK2.
\
\
\

--
Ticket URL: <https://trac.viresco.pl:8080/MATES/ticket/8#comment:2>
MATES <https://trac.viresco.pl:8080/MATES>
Modular Automatic Test Equipment System

--===============1732353417==

But there is no comment in the html part:

<body>
    <div id="main">
      <div id="content" class="ticket">
        <h1 id="trac-ticket-title">
          <a href="https://trac.viresco.pl:8080/MATES/ticket/8">Ticket #8</a>
          <span class="status">(new task)</span>
        </h1>
        <hr/>
        <div id="ticket" class="trac-content ">
  <div class="date">
    <p>Opened <span title="7 months ago">2013-07-03T11:43:13+02:00</span></p>
    <p>Last modified <span title="0 seconds ago">2014-01-24T09:30:12+01:00</span></p>
  </div>
  <h2>
    <a href="https://trac.viresco.pl:8080/MATES/ticket/8" class="trac-id">#8</a>
    <span class="trac-status">
      <a href="https://trac.viresco.pl:8080/MATES/query?status=new">new</a>
    </span>
    <span class="trac-type">
      <a href="https://trac.viresco.pl:8080/MATES/query?status=!closed&amp;type=task">task</a>
    </span>
  </h2>
  <h1 id="trac-ticket-title" class="searchable">
    <span class="summary">Generatory przebiegów realizowane programowo</span>
  </h1>
  <table class="properties">
    <tr>
      <th id="h_reporter">Reported by:</th>
      <td headers="h_reporter" class="searchable"><a href="https://trac.viresco.pl:8080/MATES/query?status=!closed&amp;reporter=Lukasz">Lukasz</a></td>
      <th id="h_owner">Owned by:</th>
      <td headers="h_owner"><a href="https://trac.viresco.pl:8080/MATES/query?status=!closed&amp;owner=Lukasz">Lukasz</a></td>
    </tr>
    <tr>
        <th id="h_priority">
          Priority:
        </th>
        <td headers="h_priority">
              <a href="https://trac.viresco.pl:8080/MATES/query?status=!closed&amp;priority=minor">minor</a>
        </td>
        <th id="h_milestone">
          Milestone:
        </th>
        <td headers="h_milestone">
              <a class="missing milestone">VTB-1425_PCU prototyp</a>
        </td>
    </tr><tr>
        <th id="h_component">
          Component:
        </th>
        <td headers="h_component">
              <a href="https://trac.viresco.pl:8080/MATES/query?status=!closed&amp;component=MATES-DIO3-MK1+firmware">MATES-DIO3-MK1 firmware</a>
        </td>
        <th id="h_version">
          Version:
        </th>
        <td headers="h_version">
              <a href="https://trac.viresco.pl:8080/MATES/query?status=!closed&amp;version=0.9+-+prototypy+MK1">0.9 - prototypy MK1</a>
        </td>
    </tr><tr>
        <th id="h_keywords" class="missing">
          Keywords:
        </th>
        <td headers="h_keywords" class="searchable">
        </td>
        <th id="h_cc" class="missing">
          Cc:
        </th>
        <td headers="h_cc" class="searchable">
        </td>
    </tr>
  </table>
  <div class="description">
    <h3 id="comment:description">
      Description
    </h3>
    <div class="searchable" xml:space="preserve">
      <p>
Dla 3 (lub 4) kanałów należy przewidzieć sprzętowo - programowy (z użyciem timerów) generator przebiegów.<br />
</p>

    </div>
  </div>
</div>
      </div>
    </div>
    <div id="footer">
      <hr/>
      <p>
        Ticket URL: &lt;<a href="https://trac.viresco.pl:8080/MATES/ticket/8#comment:2">https://trac.viresco.pl:8080/MATES/ticket/8#comment:2</a>&gt;<br/>
        MATES &lt;<a href="https://trac.viresco.pl:8080/MATES">https://trac.viresco.pl:8080/MATES</a>&gt;<br/>
        Modular Automatic Test Equipment System
      </p>
    </div>
  </body>

comment:6 Changed 4 years ago by anonymous

I also do not get comments. Trac Version 1.0.1

comment:7 Changed 4 years ago by Jun Omae

Keywords: needinfo removed

Thanks for the information. But I cannot reproduce it with Trac 0.12.5 and 1.0.1 using SQLite.

Could you please post "System Information" and "Installed Plugins" of "About Trac" page in your trac?

comment:8 in reply to:  7 Changed 4 years ago by Lukasz Matecki <lukasz.matecki@…>

Replying to jun66j5:

Thanks for the information. But I cannot reproduce it with Trac 0.12.5 and 1.0.1 using SQLite.

Could you please post "System Information" and "Installed Plugins" of "About Trac" page in your trac?

Sure !

Package	Version
Trac 	1.1.1
Babel 	0.9.6
Genshi 	0.7 (without speedups)
Pygments 	1.5
pysqlite 	2.6.0
Python 	2.7.1 (r271:86832, Nov 27 2010, 18:30:46) [MSC v.1500 32 bit (Intel)]
pytz 	2011c
RPC 	1.1.2
setuptools 	0.6c11
SQLite 	3.6.21
Subversion 	1.7.5 (r1336830)
jQuery	1.8.3

and

Name	Version	Location
TicketPatch 	N/A 	h:\trac\utal\plugins\TicketPatch.pyc
tracaccountmanager 	0.4.2 	c:\python27\lib\site-packages\tracaccountmanager-0.4.2-py2.7.egg
tracdoxygen 	0.11.0.2 	c:\python27\lib\site-packages\tracdoxygen-0.11.0.2-py2.7.egg
tracfilelist 	0.1 	c:\python27\lib\site-packages\tracfilelist-0.1-py2.7.egg
trachtmlnotificationplugin 	0.12.0.1 	c:\python27\lib\site-packages\trachtmlnotificationplugin-0.12.0.1-py2.7.egg
trachttpauth 	1.1 	c:\python27\lib\site-packages\trachttpauth-1.1-py2.7.egg
tracstats 	0.5 	c:\python27\lib\site-packages\tracstats-0.5-py2.7.egg
tracxmlrpc 	1.1.2 	c:\python27\lib\site-packages\tracxmlrpc-1.1.2-py2.7.egg

comment:9 Changed 4 years ago by weirdo

Here is mine

System Information
Package	Version
Trac 	1.0.1
Genshi 	0.7 (with speedups)
mod_wsgi 	3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 	2.6.0
Python 	2.7.3 (default, Sep 26 2013, 20:13:52) [GCC 4.6.3]
setuptools 	0.6
SQLite 	3.7.9
Subversion 	1.6.17 (r1128011)
jQuery	1.7.2
Installed Plugins
Name	Version	Location
TracDynamicFields 	1.2.3 	/var/trac/sites/plugins/TracDynamicFields-1.2.3-py2.7.egg
TracHtmlNotificationPlugin 	0.12.0.1 	/var/trac/sites/plugins/TracHtmlNotificationPlugin-0.12.0.1-py2.7.egg
Last edited 4 years ago by weirdo (previous) (diff)

comment:10 Changed 4 years ago by weirdo

Think I have worked out what the issue is.

If I create an anonymous subject with TICKET_VIEW permissions it then works.

We do not have anonymous as we do not want everyone having access to the system.

Is there a way to change the user the email uses.

Hope this helps find a fix.

comment:11 in reply to:  10 Changed 4 years ago by Jun Omae

Status: newaccepted

Replying to weirdo:

If I create an anonymous subject with TICKET_VIEW permissions it then works.

Reproduced with the help. Thanks for the great information! I'll fix it soon.

comment:12 Changed 4 years ago by Jun Omae

In 13615:

trachtmlnotification: fixed missing comment of ticket in text/html part if anonymous doesn't have TICKET_VIEW permission (refs #11368)

comment:13 Changed 4 years ago by Jun Omae

I fixed this issue and other issues. Please try [13618] or later.

comment:14 Changed 4 years ago by weirdo

Works great. Thank you very much. A very useful plugin.

comment:15 Changed 4 years ago by weirdo

A few more test and it looks like a code block in the comments or wiki formatting does not display any of the comment.

Changed 4 years ago by Jun Omae

Attachment: htmlmail-1390834904.png added

comment:16 Changed 4 years ago by Jun Omae

It seems that a code block in the ticket comment works well in html mail....

comment:17 Changed 4 years ago by Lukasz Matecki <lukasz.matecki@…>

Works OK for me, thanks !

comment:18 in reply to:  15 Changed 4 years ago by Jun Omae

Resolution: fixed
Status: acceptedclosed

Replying to weirdo:

A few more test and it looks like a code block in the comments or wiki formatting does not display any of the comment.

It seems to be another issue or not a issue. I've fixed the original issue. Please create a new ticket if needed. Thanks.

Last edited 4 years ago by Jun Omae (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.