Modify

Opened 4 years ago

Closed 4 years ago

#11420 closed defect (duplicate)

TypeError: 'NoneType' object is unsubscriptable

Reported by: vinay.mohan.dass Owned by: Radek Bartoň
Priority: normal Component: DiscussionPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a POST operation on /admin/discussion/forum, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'2635e2d315333c0f49d5b1bd',
 'cat_id': u'discussion',
 'discussion_action': u'delete',
 'group': '-1',
 'panel_id': u'forum',
 'path_info': None,
 'remove': u'Remove selected items',
 'selection': u'2'}

User agent: Mozilla/5.0 (Windows NT 6.0; rv:25.0) Gecko/20100101 Firefox/25.0

System Information

Trac 0.12.3
Trac 0.12.3
Babel 0.9.5
Docutils 0.7
Genshi 0.6
GIT 1.8.4
mod_wsgi 2.5 (WSGIProcessGroup trac_wsgi_01 WSGIApplicationGroup %{GLOBAL})
Pygments 1.4dev-20110115
pysqlite 2.4.1
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
pytz 2008c
pytz 2008c
RPC 1.1.2
setuptools 0.6c12
setuptools 0.6c12
SQLite 3.7.3
Subversion 1.8.3 (r1516576)
jQuery 1.4.4

Enabled Plugins

backlinks N/A
backlinks-menu N/A
customroadmap.webadminui N/A
TracAnnouncer 0.12.1.dev
TracCaptcha 0.2.2
TracCustomRoadmap 0.4
TracDiscussion 0.8-r9877
TracDownloads 0.3
TracGit 0.12.0.5dev
TracMarkdownMacro 0.11.1
tracrpc.changeset N/A
TracTags 0.6
TracTocMacro 11.0.0.3
TracWysiwyg 0.12.0.3-r9676
TracXMLRPC 1.1.2

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/admin/web_ui.py", line 117, in process_request
    path_info)
  File "/usr/local/lib/python2.5/site-packages/TracDiscussion-0.8_r9877-py2.5.egg/tracdiscussion/admin.py", line 49, in render_admin_panel
    template, data = api.process_discussion(context)
  File "/usr/local/lib/python2.5/site-packages/TracDiscussion-0.8_r9877-py2.5.egg/tracdiscussion/api.py", line 259, in process_discussion
    self._do_actions(context, actions)
  File "/usr/local/lib/python2.5/site-packages/TracDiscussion-0.8_r9877-py2.5.egg/tracdiscussion/api.py", line 880, in _do_actions
    listener.forum_deleted(context, context.forum)
  File "/usr/local/lib/python2.5/site-packages/TracDiscussion-0.8_r9877-py2.5.egg/tracdiscussion/tags.py", line 73, in forum_deleted
    forum['id']))
TypeError: 'NoneType' object is unsubscriptable

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Ryan J Ollos

Component: SELECT A HACKDiscussionPlugin
Owner: changed from anonymous to Radek Bartoň

comment:2 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #9220. Please upgrade your DiscussionPlugin installation and you will likely find that the issue is fixed. If not, please let us know.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Radek Bartoň.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.