Modify

Opened 2 years ago

Closed 8 months ago

#11561 closed defect (worksforme)

Clone ticket body gets clobbered by ticket template

Reported by: russellballestrini Owned by: richard
Priority: normal Component: TracTicketTemplatePlugin
Severity: normal Keywords:
Cc: travfischer@…, russellballestrini Trac Release: 1.0

Description (last modified by rjollos)

There is a defect that occurs when TracTicketTemplatePlugin is enabled and a user clicks the clone button. The new ticket is cloned properly, then the TicketTemplatePlugin's Javascript fires and clobbers the cloned description.

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by russellballestrini

  • Cc russellballestrini added

comment:2 Changed 8 months ago by anonymous

Same problem here.

I would really like to use both plugins, but had to turn off TracTicketTemplatePlugin in order to avoid this negative side effect on cloning.

Any suggestion or workaround is welcome.

Last edited 8 months ago by rjollos (previous) (diff)

comment:3 Changed 8 months ago by rjollos

  • Description modified (diff)

comment:4 Changed 8 months ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

I tested with the 1.0 branch of TracTicketTemplatePlugin and Trac 1.0.9. The argument preview is set when submitting Clone and TracTicketTemplatePlugin doesn't reapply the template.

If you have the latest TracTicketTemplatePlugin installed and can reproduce, please provide more details. Thanks.

Add Comment

Modify Ticket

Action
as closed The owner will remain richard.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.