Modify

Opened 3 years ago

Closed 3 years ago

#11583 closed defect (duplicate)

Submit Review causes error

Reported by: Scott Owned by: Rob Guttman
Priority: normal Component: CodeReviewerPlugin
Severity: blocker Keywords:
Cc: Trac Release: 1.0

Description

I am running with 1.0.1

2014-02-19 07:20:40,866 Trac[main] DEBUG: Dispatching <RequestWithSession "POST '/changeset/1980/vlab_ocp'">
2014-02-19 07:20:40,867 Trac[session] DEBUG: Retrieving session for ID 'shr'
2014-02-19 07:20:40,884 Trac[main] DEBUG: Negotiated locale: None -> en_US
2014-02-19 07:20:40,917 Trac[api] INFO: Synchronized '(default)' repository in 0.05 seconds
2014-02-19 07:20:40,930 Trac[chrome] DEBUG: Prepare chrome data for request
2014-02-19 07:20:41,045 Trac[main] ERROR: Exception caught while post-processing request: 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 243, in dispatch
    self._post_process_request(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 340, in _post_process_request
    f.post_process_request(req, *(None,)*extra_arg_count)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 59, in post_process_request
    tickets = self._update_tickets(req, review)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 127, in _update_tickets
    changeset = repo.get_changeset(review.changeset)
AttributeError: 'NoneType' object has no attribute 'get_changeset'
2014-02-19 07:20:41,045 Trac[main] ERROR: Internal Server Error: 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 224, in dispatch
    self._post_process_request(req, *resp)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 338, in _post_process_request
    resp = f.post_process_request(req, *resp)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 59, in post_process_request
    tickets = self._update_tickets(req, review)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 127, in _update_tickets
    changeset = repo.get_changeset(review.changeset)
AttributeError: 'NoneType' object has no attribute 'get_changeset'

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by Scott

Resolution: duplicate
Status: newclosed

Duplicate of #10834

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Rob Guttman.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.