Modify

Opened 8 years ago

Closed 8 years ago

#11756 closed defect (duplicate)

IOError: [Errno 2] No such file or directory: ''

Reported by: zzinggu@… Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'2491fbe7b93cd72de627ddc9',
 'add': u' Add ',
 'cat_id': u'accounts',
 'email': u'zzinggu@chronohive.com',
 'name': u'zzinggu',
 'panel_id': u'users',
 'password': u'2580',
 'password_confirm': u'2580',
 'path_info': None,
 'username': u'zzinggu'}

User agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.132 Safari/537.36

System Information

Trac 1.1.2dev-r12805
Babel 1.0dev-r661
Docutils 0.11
Genshi 0.8dev-r1269 (without speedups)
mod_python 3.3.1
Pygments 1.6
pysqlite 2.6.0
Python 2.7.3 (default, Feb 27 2014, 20:09:21)
[GCC 4.6.3]
pytz 2014.3
setuptools 0.6
SQLite 3.7.9
jQuery 1.8.3
jQuery UI 1.9.2
jQuery Timepicker 1.1.1

Enabled Plugins

TracAccountManager 0.4.4

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.1.2dev_r12805-py2.7.egg/trac/web/main.py", line 531, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.1.2dev_r12805-py2.7.egg/trac/web/main.py", line 223, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.1.2dev_r12805-py2.7.egg/trac/admin/web_ui.py", line 124, in process_request
    path_info)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/admin.py", line 204, in render_admin_panel
    return self._do_users(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/admin.py", line 348, in _do_users
    acctmgr.validate_registration(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/api.py", line 367, in validate_registration
    self.set_password(username, req.args.get('password'))
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/api.py", line 245, in set_password
    if store.set_password(user, password, old_password):
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/htfile.py", line 55, in set_password
    self.userline(user, password))
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/htfile.py", line 158, in _update_file
    f = open(filename, 'w')
IOError: [Errno 2] No such file or directory: ''

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #9623.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.