Modify

Opened 10 years ago

Closed 9 years ago

#1181 closed defect (fixed)

Tags does not obey WIKI_VIEW permission

Reported by: kkatzke@… Owned by: Alec Thomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords:
Cc: Myroslav Opyr Trac Release: 0.10

Description

Witnessed Behavior:

  • Tags menu option is still visible when ANONYMOUS user has no permissions at all
  • Tags are viewable in the menu

Expected behavior:

  • Tags menu option is not visible
  • Tags will not be visible when wiki_view permission is not available for user.

Attachments (1)

tagsplugin-withperms.patch (3.1 KB) - added by Mike Buzzetti 10 years ago.
Patch to add TAGS permssions

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by Noah Kantrowitz

This would not be the correct behavior, as you can tag things other than wiki pages. A better solution would be to have the wiki tagspace activate only when the user has WIKI_VIEW.

comment:2 Changed 10 years ago by Radek Bartoň

I would prefer to append aditional permission TAGS_VIEW since I'd like to disallow anonymous users to see "Tags" button even if they have WIKI_VIEW permission. Then it will be necessary to have TAGS_VIEW to view "Tags" button and other permissions to view apropriate content pf tags cloud. If you like I can write and post patch doing that here.

Changed 10 years ago by Mike Buzzetti

Attachment: tagsplugin-withperms.patch added

Patch to add TAGS permssions

comment:3 Changed 10 years ago by Mike Buzzetti

I have implemented proper permisions for this and attached it

comment:4 Changed 10 years ago by Myroslav Opyr

Cc: Myroslav Opyr added; anonymous removed

comment:5 Changed 9 years ago by Alec Thomas

Resolution: fixed
Status: newclosed

TagsPlugin 0.6 natively supports 0.11 fine-grained permissions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Alec Thomas.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.