Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11819 closed defect (duplicate)

Adding path containing umlaut gives trac internal error

Reported by: support@… Owned by: Ryan J Ollos
Priority: normal Component: SvnAuthzAdminPlugin
Severity: critical Keywords:
Cc: Trac Release: 1.0

Description (last modified by Ryan J Ollos)

Oops…
Trac detected an internal error:
KeyError: u'\xfc'

When I try to add a SVN path containing e.g. an "ü"

Normally, Subversion is as UTF-8 safe as the underlying file system, so svnauthz should be too.

Python Traceback

Most recent call last:
File "/usr/lib64/python2.7/site-packages/trac/web/main.py", line 497, in _dispatch_request
File "/usr/lib64/python2.7/site-packages/trac/web/main.py", line 214, in dispatch
File "/usr/lib64/python2.7/site-packages/trac/admin/web_ui.py", line 125, in process_request
File "/usr/lib64/python2.7/site-packages/SvnAuthzAdminPlugin-0.2-py2.7.egg/svnauthz/admin_ui.py", line 102, in render_admin_panel
File "/usr/lib64/python2.7/urllib.py", line 60, in pathname2url
File "/usr/lib64/python2.7/urllib.py", line 1268, in quote

SvnAuthzAdminPlugin 0.2

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #7348.

comment:2 Changed 3 years ago by Ryan J Ollos

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.