Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#11916 closed defect (worksforme)

Trac 1.0.1: "excel w/ history" missing in query view

Reported by: Theodor Norup Owned by: Jun Omae
Priority: normal Component: ExcelDownloadPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description (last modified by Jun Omae)

Have a trac instance with the configuration shown below.

At the bottom of the Report Views (ie Query), I only see the "Excel" download link; at the bottom of an individual ticket page I see "Excel with history". Both links produce the expected results.

I have tried to modify the plugin code and have come as far as determining that the Query page link is rendered by the _add_alternate_links in ticket.py line 481.

Further analysis seems to be beyond me, at least without qualified guidance; let me know if there is anything I can do.

System Information

Package Version
Trac 1.0.1
Docutils 0.11
Genshi 0.7 (with speedups)
mod_wsgi 3.4 (WSGIProcessGroup trac WSGIApplicationGroup %{GLOBAL})
psycopg2 2.5.2
Pygments 1.6
Python 2.7.6 (default, Mar 22 2014, 23:03:41) [GCC 4.8.2]
pytz 2012c
RPC 1.1.2-r13776
setuptools 3.3
Subversion 1.8.8 (r1568071)
jQuery 1.7.2

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Jun Omae

Description: modified (diff)

comment:2 Changed 3 years ago by Jun Omae

Resolution: worksforme
Status: newclosed

Works for me. I just confirmed that;

  • The query page (/query) has both "excel" link and "excel w/ history" link.
  • The report page (e.g. /report/1) has only "excel" link. This page does NOT has "excel w/ history" link.
Last edited 3 years ago by Jun Omae (previous) (diff)

comment:3 Changed 3 years ago by Theodor Norup

Ahhhh, I had never realised that the custom queries not just add extra parameters to the report URL but instead have a completely different URL. Obviously, I had tried the first only. So, yes, works nicely, thanks, sorry for the inconvenience.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.