Modify

Opened 4 years ago

Closed 4 years ago

#12002 closed defect (fixed)

Test stats tab not displaying the test status and chart

Reported by: thomson@… Owned by: Roberto Longobardi
Priority: highest Component: TestManagerForTracPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.12

Description

Hi, I have installed the latest trac plugin for test manager. I could add test cases by creating test catalogs and I have also created test plan. The only problem I am facing right now is I could not view the test status in 'Test Stats' tab. Please refer to the attachment. Please help me in getting rid of this issue.

Thanks, Thomson

Attachments (2)

TestStats_1.jpg (54.4 KB) - added by thomson@… 4 years ago.
TestStats issue
F12_logs.jpg (323.4 KB) - added by thomson@… 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by thomson@…

Attachment: TestStats_1.jpg added

TestStats issue

comment:1 Changed 4 years ago by thomson@…

Hi, Could you please let me know the status of this ticket. Thanks, Thomson

comment:2 Changed 4 years ago by Roberto Longobardi

Hi Thomson, to help me debug your issue, could you please specify the following details:

  • your client operating system (i.e. from where you browse Trac),
  • the browser you use.

Since it looks like a Javascript problem to me, could you enable the browser javascript console, by pressing F12 in your browser, and then reproduce the problem? Then, take a look at the javascript console and report here any error you may see.

Thanks, ciao. Roberto

comment:3 Changed 4 years ago by thomson@…

Hi Roberto,

Thanks a lot for your response. Please find the details below

  • Operating System : Windows 7 Professional, Service Pack 1
  • Browser : Mozilla Firefox 34.0.5

Please find the F12 logs herewith:

GET https://vmsvr1.dev.vespermarine.com:39149/teststats [HTTP/1.1 200 OK 208ms]
Unknown property '-moz-box-shadow'.  Declaration dropped. stats.css:84
Expected 'none' or URL but found 'Alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:51
Expected 'none' or URL but found 'alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:608
Expected 'none' or URL but found 'Alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:909
Expected 'none' or URL but found 'Alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:916
Expected 'none' or URL but found 'Alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:920
Expected 'none' or URL but found 'Alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:1168
Expected 'none' or URL but found 'Alpha('.  Error in parsing value for 'filter'.  Declaration dropped. jquery-ui-1.10.3.custom.css:1175
Loading mixed (insecure) display content on a secure page "http://downloads.vespermarine.com/vespermarine-color250x49.png"[Learn More] teststats
Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/ jquery-1.9.1.js:8492
GET https://teststats/ [2552ms]
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://teststats/?content=chartdata&start_date=18/09/14&end_date=17/12/14&resolution=7&testplan=__all. This can be fixed by moving the resource to the same domain or enabling CORS. teststats
TypeError: data.testActivity is undefined stats.js:80
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. jquery-1.9.1.js:3346
GET https://teststats/ [2553ms]
Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://teststats/?content=chartdata&start_date=18/09/14&end_date=17/12/14&resolution=7&testplan=4|TC_TT46. This can be fixed by moving the resource to the same domain or enabling CORS. teststats
TypeError: data.testActivity is undefined stats.js:80

Also, I have attached the snapshot for reference.

Please let me know if anything to be done from my side.

Best regards, Thomson

Changed 4 years ago by thomson@…

Attachment: F12_logs.jpg added

comment:4 Changed 4 years ago by anonymous

Hi Roberto,

Please let me know if there is any breakthrough on this issue.

Best regards, Thomson

comment:5 Changed 4 years ago by thomson@…

Hi Roberto,

Could you please let me know if there is any status update on this ticket. Did you get a chance to go through the logs?

Best regards, Thomson

comment:6 Changed 4 years ago by Roberto Longobardi

Hi Thomson, I'm sorry I'm answering so late.

From the log I see there's something wrong with how URLs are created for the test statistics stuff: at some point they read like "https://teststats/..." when they should be "https://vmsvr1.dev.vespermarine.com:39149/teststats/..."

I think there may a problem with your trac.ini configuration or with the plugin's leveraging of the Trac's support for NAT.

What do you have in your trac.ini file for the "url", "base_url" and "use_base_url_for_redirect" properties?

Refer to here for details about their use: http://trac.edgewall.org/wiki/0.12/TracIni

Please, let me know.

Ciao, Roberto

comment:7 Changed 4 years ago by anonymous

hi guys,

I am integrating this plugin with my Trac env. and suffering from this issue these days, today I have found the reason: if you start your single project Trac instance using tracd with “-s” argument, the URL displayed in your browser's URL textbox will not include your project directory, and then in browser's F12 panel the stats.js with throw an error says like "variable 'series' can not be NULL or undefined", at that time the variable urlAddress will be like this "xxxxx"(I guess to make it work this variable should be like "/yourPrjFoldername/xxxxx").

to avoid this, just start your Trac instance without "-s" argument.

Tested with TM plugin ver 1.8.2+Trac 1.0.3

comment:8 Changed 4 years ago by Roberto Longobardi

Resolution: fixed
Status: newclosed

Hi there, thanks a lot for your debugging and for sharing the results here.

Now I understand why I couldn't reproduce the problem... I didn't even know about the -s option! :)

I'll close this ticket as solved, and I'll add your information to the wiki asap.

Thanks, ciao. Roberto

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Roberto Longobardi.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.