Modify

Opened 7 years ago

Closed 5 years ago

#12084 closed defect (fixed)

NameError: global name 'otherID' is not defined

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: ValuePropagationPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description (last modified by Ryan J Ollos)

Prerequisite: trac.ini ...

[value_propagation]
r1.fields=hours
r1.link=parents
r1.method.hours=sum
r1.type=link

Reproduction steps:

  1. New Ticket
  2. Setting Estimation Hours
  3. Adding Hours
  4. Set Parent Ticket Relation

Setting the parent ticket from an existing ticket with an estimation, value propagation plugin shows an error that 'otherID' is not defined.

2014-12-01 13:53:58,016 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/site-packages/trac/ticket/web_ui.py", line 179, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.7/site-packages/trac/ticket/web_ui.py", line 614, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/lib/python2.7/site-packages/trac/ticket/web_ui.py", line 1328, in _do_save
    replyto=req.args.get('replyto'))
  File "/usr/lib/python2.7/site-packages/trac/ticket/model.py", line 365, in save_changes
    listener.ticket_changed(self, comment, author, old_values)
  File "build/bdist.linux-x86_64/egg/valuepropagation/valuepropagation.py", line 361, in ticket_changed
    self.types[v](p[0], ticket, old_values)
  File "build/bdist.linux-x86_64/egg/valuepropagation/valuepropagation.py", line 251, in _handle_link
    self._propagate(r, ticket, old_values, oldOtherID, newOtherID)
  File "build/bdist.linux-x86_64/egg/valuepropagation/valuepropagation.py", line 275, in _propagate
    if newOtherID == oldOtherID or otherID == '':
NameError: global name 'otherID' is not defined

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 5 years ago by Ryan J Ollos

Owner: changed from Chris Nelson to Ryan J Ollos
Status: newaccepted

comment:3 Changed 5 years ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 16190:

1.2.0dev: Adapt to Trac 1.2 API

  • Fix variable referenced before assigned, fixes #12084
  • Fix attribute error due to int cnum, fixes #11033

Fixes #13038.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.