Modify

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#12086 closed defect (duplicate)

DatePicker does not work if DynamicFieldsPlugin is used

Reported by: gmx@… Owned by: Ryan J Ollos
Priority: normal Component: DateFieldPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

The datepicker is not added to the textfile if the DynamicFieldsPlugin (TracDynamicFields 2.2.0dev) is used.

Deactivating dynfields.web_ui.* DynamicFieldsModule — A module that dynamically alters ticket fields based an extensible set of rules. Uses jQuery for full implementation. lets the DatePicker appear again.

Is there another solution to have both runnin side by side?

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by Ryan J Ollos

Which version of Trac are you running? Which version of DateFieldPlugin are you running?

Based on the version of DynamicFieldsPlugin you report, you've installed from the dynamicfieldsplugin/0.12 branch. It is suggested that you run the dynamicfieldsplugin/0.11 branch (though that likely won't fix the issue you are experiencing here). The DynamicFieldsPlugin 0.11 branch is compatible with Trac 0.11 and has many fixes that haven't been ported to the DynamicFieldsPlugin 0.12 branch.

comment:2 Changed 7 years ago by Ryan J Ollos

I did some quick testing with Trac 1.0-stable and the two plugins seems to work okay together. I'll need the info requested in comment:1 to debug further. Please also post your [ticket-custom] section.

comment:3 Changed 7 years ago by gmk@…

Trac Environment

Package Version
Trac 1.0
Babel 0.9.5
Genshi 0.6 (without speedups)
GIT 1.7.10.4
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
psycopg2 2.4.5
Pygments 1.5
Python 2.7.3 (default, Mar 14 2014, 12:14:27) [GCC 4.7.2]
RPC 1.1.2-r13776
setuptools 0.6
Subversion 1.6.17 (r1128011)
jQuery 1.7.2

Related Plugins

TracDateField 3.0.0dev-r13931
TracDynamicFields 2.2.0dev

trac.ini

[ticket-custom]
billable = checkbox
billable.label = Billable?
billable.order = 9
billable.value = 1
blockedby = text
blockedby.format = plain
blockedby.label = Blocked By
blockedby.order = 0
blockedby.value = 
blocking = text
blocking.format = plain
blocking.label = Blocking
blocking.order = 1
blocking.value = 
estimatedhours = text
estimatedhours.format = plain
estimatedhours.label = Estimated Number of Hours
estimatedhours.order = 5
estimatedhours.value = 0
hours = text
hours.format = plain
hours.label = Add Hours to Ticket
hours.order = 8
hours.value = 0
internal = checkbox
internal.label = Internal?
internal.order = 10
internal.value = 0
parent = text
parent.format = wiki
parent.label = Parent ID
parent.order = 2
parent.value = 
publicchangelist = checkbox
publicchangelist.label = Public Changes List?
publicchangelist.order = 13
publicchangelist.value = 
queueplanpos = text
queueplanpos.clear_on_hide = false
queueplanpos.format = plain
queueplanpos.hide_always = true
queueplanpos.label = Planed Queue
queueplanpos.order = 12
queueplanpos.value = 
queuepos = text
queuepos.format = plain
queuepos.label = Queue Pos
queuepos.order = 11
queuepos.value = 
sched_end = text
sched_end.date = true
sched_end.date_empty = on
sched_end.format = plain
sched_end.label = End Date
sched_end.order = 4
sched_end.value = 
sched_start = text
sched_start.date = true
sched_start.date_empty = on
sched_start.format = plain
sched_start.label = Start Date
sched_start.order = 3
sched_start.value = 
totalhours = text
totalhours.format = plain
totalhours.label = Total Hours
totalhours.order = 6
totalhours.value = 0
Last edited 7 years ago by Ryan J Ollos (previous) (diff)

comment:4 Changed 7 years ago by Ryan J Ollos

Status: newaccepted

comment:5 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: acceptedclosed

You configuration works correctly with the dynamicfieldsplugin/0.11 branch (currently at version 1.2.6). I can reproduce the problem you are experiencing with the dynamicfieldsplugin/0.12 branch. The error is:

TypeError: th.attr(...) is undefined layout.js:156

It looks like this was fixed on the 0.11 branch in [11520] / #9605.

The 0.12 branch has not been maintained. The solution for now is to install from the 0.11 branch. The i18n changes on the 0.12 branch will be combined with the code on the 0.11 branch in #12112.

Closing as a duplicate of #9605.

comment:6 Changed 5 years ago by anonymous

Any update on this? The dynamic fields plugin still does not work with date picker. I'm using trac 1.3.1.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.