Modify

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#12286 closed defect (fixed)

If I click on Ticketsboard I get an error

Reported by: anonymous Owned by: jpsave
Priority: normal Component: TicketsBoardPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/api.py", line 441, in send_error
    data, 'text/html')
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 870, in render_template
    encoding='utf-8')
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 183, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/usr/local/lib64/python2.6/site-packages/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "/usr/local/lib64/python2.6/site-packages/genshi/output.py", line 339, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/output.py", line 826, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/output.py", line 670, in __call__
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/output.py", line 771, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "/usr/local/lib64/python2.6/site-packages/genshi/output.py", line 586, in __call__
    for ev in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 984, in _strip_accesskeys
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 973, in _generate
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/filters/transform.py", line 686, in _unmark
    for mark, event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/filters/transform.py", line 1175, in __call__
    for mark, (kind, data, pos) in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/filters/transform.py", line 714, in __call__
    for mark, event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/filters/transform.py", line 682, in _mark
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/markup.py", line 327, in _match
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 565, in _flatten
    result = _eval_expr(data, ctxt, vars)
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/base.py", line 277, in _eval_expr
    retval = expr.evaluate(ctxt)
  File "/usr/local/lib64/python2.6/site-packages/genshi/template/eval.py", line 178, in evaluate
    return eval(self.code, _globals, {'__data__': data})
  File "/tmp/Trac-0.12.3-py2.6.egg-tmp/trac/templates/error.html", line 165, in <Expression u'shorten_line(repr(value))'>
    <td><code>${shorten_line(repr(value))}</code></td>
  File "build/bdist.linux-x86_64/egg/mastertickets/model.py", line 145, in __repr__
    (self.tkt.id, l(getattr(self, 'blocking', [])), l(getattr(self, 'blocked_by', [])))
AttributeError: 'TicketLinks' object has no attribute 'tkt'

Attachments (0)

Change History (11)

comment:1 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 6 years ago by Ryan J Ollos

In 14696:

Added missing __init__.py. Refs #12286.

comment:3 Changed 6 years ago by Ryan J Ollos

[14696] fixes the following error seen with failure to load plugin:

12:27:24 Trac[loader] ERROR: Skipping "ticketsboardplugin.web_ui = ticketsboardplugin.web_ui": 
Traceback (most recent call last):
  File "/Users/rjollos/t12286/pve/lib/python2.7/site-packages/trac/loader.py", line 68, in _load_eggs
    entry.load(require=True)
  File "/Users/rjollos/t12286/pve/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2310, in load
    return self.resolve()
  File "/Users/rjollos/t12286/pve/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2316, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/Users/rjollos/t12286/ticketsboardplugin/0.12/trunk/ticketsboardplugin/web_ui.py", line 221

comment:4 Changed 6 years ago by Ryan J Ollos

In 14697:

Fixed improper encoding signature for file with non-ascii character.

Refs #12286.

comment:5 Changed 6 years ago by Ryan J Ollos

[14697] fixes the following error seen with failure to load plugin:

12:27:45 Trac[loader] ERROR: Skipping "ticketsboardplugin.web_ui = ticketsboardplugin.web_ui": 
Traceback (most recent call last):
  File "/Users/rjollos/t12286/pve/lib/python2.7/site-packages/trac/loader.py", line 68, in _load_eggs
    entry.load(require=True)
  File "/Users/rjollos/t12286/pve/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2310, in load
    return self.resolve()
  File "/Users/rjollos/t12286/pve/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2316, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/Users/rjollos/t12286/ticketsboardplugin/0.12/trunk/ticketsboardplugin/web_ui.py", line 221
SyntaxError: Non-ASCII character '\xc2' in file /Users/rjollos/t12286/ticketsboardplugin/0.12/trunk/ticketsboardplugin/web_ui.py on line 221, but no encoding declared; see http://python.org/dev/peps/pep-0263/ for details (web_ui.py, line 221)

comment:6 Changed 6 years ago by Ryan J Ollos

In 14698:

Define options on TicketsboardPage class. Refs #12286.

comment:7 Changed 6 years ago by Ryan J Ollos

TicketsBoardPlugin is working for me now. I hope you don't mind that I pushed those fixes, but there were some blocking defects. I'll investigate now whether the issue is with TicketsBoardPlugin or MasterTicketsPlugin.

comment:8 Changed 5 years ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

comment:9 Changed 5 years ago by Ryan J Ollos

In 16180:

1.2.2: Prepare to release version 1.2.2

Refs #12286.

comment:10 Changed 5 years ago by Ryan J Ollos

In 16181:

1.2.2: Tag version 1.2.2

Refs #12286.

comment:11 Changed 5 years ago by Ryan J Ollos

In 16182:

1.2.3-trac0.12dev: Bump version to 1.2.3

Refs #12286.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jpsave.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.