Modify

Opened 7 years ago

Closed 7 years ago

#12378 closed defect (duplicate)

IndexError: list index out of range

Reported by: willem Owned by: Ryan J Ollos
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a POST operation on /newticket, Trac issued an internal error.

This is just after new install of MasterTickets

Request parameters:

{'__FORM_TOKEN': u'f433c060ce7715e8cbbe8811',
 'field_blockedby': u'14',
 'field_blocking': u'',
 'field_cc': u'',
 'field_component': u'Generic',
 'field_description': u'tt',
 'field_keywords': u'',
 'field_milestone': u'',
 'field_owner': u'< default >',
 'field_priority': u'trivial',
 'field_reporter': u'willem',
 'field_summary': u'tesy',
 'field_type': u'defect',
 'submit': u'Create ticket'}

User agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

System Information

Trac 1.0.6post2
Genshi 0.7 (with speedups)
GIT 1.7.1
Pygments 2.0.2
pysqlite 2.4.1
Python 2.6.6 (r266:84292, Jan 22 2014, 09:42:36)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-4)]
RPC 1.1.3
setuptools 0.6
SQLite 3.6.20
jQuery 1.7.2
jQuery UI 1.8.21
jQuery Timepicker 1.0.1

Enabled Plugins

TracAccountManager 0.4.4
TracMasterTickets 4.0.0dev-r14515
TracXMLRPC 1.1.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 534, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/trac/web/main.py", line 227, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/site-packages/trac/ticket/web_ui.py", line 183, in process_request
    return self._process_newticket_request(req)
  File "/usr/lib/python2.6/site-packages/trac/ticket/web_ui.py", line 468, in _process_newticket_request
    self._do_create(req, ticket) # (redirected if successful)
  File "/usr/lib/python2.6/site-packages/trac/ticket/web_ui.py", line 1311, in _do_create
    ticket.insert()
  File "/usr/lib/python2.6/site-packages/trac/ticket/model.py", line 256, in insert
    listener.ticket_created(self)
  File "/usr/lib/python2.6/site-packages/TracMasterTickets-4.0.0dev_r14515-py2.6.egg/mastertickets/api.py", line 114, in ticket_created
    self.ticket_changed(tkt, '', tkt['reporter'], {})
  File "/usr/lib/python2.6/site-packages/TracMasterTickets-4.0.0dev_r14515-py2.6.egg/mastertickets/api.py", line 119, in ticket_changed
    links.save(author, comment, tkt.time_changed, db)
  File "/usr/lib/python2.6/site-packages/TracMasterTickets-4.0.0dev_r14515-py2.6.egg/mastertickets/model.py", line 75, in save
    """, (n, field))[0][0]
IndexError: list index out of range

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #12303.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.