Modify

Opened 7 years ago

Closed 7 years ago

#12391 closed defect (worksforme)

Macro version doesn't match the non-macro version

Reported by: kelly.a.campbell@… Owned by: Jun Omae
Priority: normal Component: TicketCalendarPlugin
Severity: normal Keywords: needinfo
Cc: Trac Release:

Description

The non-macro version doesn't look for the due_date column correctly, so different results are given when using the url handler version than the macro version.

Patch to make them both go through the same code path is attached.

Attachments (1)

query_string.patch (1.8 KB) - added by kelly.a.campbell@… 7 years ago.
Patch

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by kelly.a.campbell@…

Attachment: query_string.patch added

Patch

comment:1 Changed 7 years ago by Jun Omae

It doesn't seem the patch correctly works. Would you post how to reproduce and the details?

comment:2 Changed 7 years ago by kelly.a.campbell@…

To reproduce:

  1. Have tickets with custom fields for due_date and/or start_date (using datefield plugin):
    [ticket-custom]
    due_date = text
    due_date.date = true
    due_date.label = Due Date
    due_date.value = 
    due_date.date_empty = true
    
    [datefield]
    format = ymd
    separator = /
    
  1. Go to the Ticket Calendar link and use a query that shows the tickets on their due or start dates.
  2. Click the Macro link next to the month selector and copy the macro text.
  3. Paste the macro text into a wiki page.
  4. View the wiki page with the macro.

Expected: It should show the same as the Ticket Calendar link,

Result without patch: it shows the tickets on their creation date.

comment:3 Changed 7 years ago by Jun Omae

Works for me. Please post the details step by step.

  1. Add due_date field to [ticket-custom]
  2. Create 2 tickets with 2015/06/08 and 2015/06/09 in due_date field.
    Id         Due date
    ------------------------
    #1         2015/06/09
    #2         2015/06/08
    
  3. Visit /ticketcalendar-box and filter with due_date=2015/06/08. Current location is the following.
    /ticketcalendar-box?due_date=2015%2F06%2F08&order=priority&_month=2015-06
    
  4. Only #2 ticket is shown in ticket calendar.
  5. Click the macro link. The following text is shown.
    [[TicketCalendar(type=box,month=2015-06,query=due_date=2015/06/08,order=priority)]]
    
  6. Paste the macro in wiki page and save.
  7. Only #2 ticket is shown in the wiki page.

comment:4 Changed 7 years ago by Jun Omae

Keywords: needinfo added
Resolution: worksforme
Status: newclosed

Closing as worksforme.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.