Opened 10 years ago

Closed 10 years ago

#1242 closed defect (duplicate)


Reported by: jameslabocki@… Owned by: athomas
Priority: normal Component: PageToPdfPlugin
Severity: normal Keywords: PageToPdf UnicodeEncodeError
Cc: jameslabocki@… Trac Release: 0.10


I encounter this error while encoding a wiki page to pdf and am curious if there is something I can do to fix it. Most other pages work fine? Thanks

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/", line 387, in dispatch_request
  File "/usr/lib/python2.3/site-packages/trac/web/", line 238, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.3/site-packages/trac/wiki/", line 134, in process_request
    page.text, format,
  File "/usr/lib/python2.3/site-packages/trac/mimeview/", line 604, in send_converted
    content, selector)
  File "/usr/lib/python2.3/site-packages/trac/mimeview/", line 384, in convert_content
    output = converter.convert_content(req, mimetype, content, ck)
  File "build/bdist.linux-i686/egg/pagetopdf/", line 20, in convert_content
  File "/usr/lib/python2.3/encodings/", line 18, in encode
    return codecs.charmap_encode(input,errors,encoding_map)
UnicodeEncodeError: 'charmap' codec can't encode character u'\u2013' in position 1779: character maps to <undefined>

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by athomas

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #841.

Add Comment

Modify Ticket

as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.