Modify

Opened 7 years ago

Closed 7 years ago

#12431 closed defect (duplicate)

HTTPNotFound: 404 Not Found (Invalid URL encoding (was ...

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: VotePlugin
Severity: normal Keywords:
Cc: Steffen Hoffmann Trac Release:

Description

The following is seen in the log files. with VotePlugin 3.0.0:

2015-07-03 21:09:49,055 Trac[main] ERROR: Exception caught while post-processing request:
Traceback (most recent call last):
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/Trac-1.0.6post2-py2.6.egg/trac/web/main.py", line 257, in dispatch
    self._post_process_request(req)
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/Trac-1.0.6post2-py2.6.egg/trac/web/main.py", line 370, in _post_process_request
    f.post_process_request(req, *(None,)*extra_arg_count)
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/TracVote-0.3.0-py2.6.egg/tracvote/__init__.py", line 389, in post_process_request
    if fnmatchcase(req.path_info, path) and \
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/Trac-1.0.6post2-py2.6.egg/trac/web/api.py", line 380, in path_info
    path_info=path_info))
HTTPNotFound: 404 Not Found (Invalid URL encoding (was '/wiki/PhpBbAuthPlugin+++++++++++++++++++++++++++++++++++++++Result:+\xe8\xf1\xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xed+\xed\xe8\xea\xed\xe5\xe9\xec+"KennethCaf";+\xe7\xe0\xe2\xe5\xf0\xf8\xe5\xed\xee+\xef\xf0\xe8+\xef\xee\xef\xfb\xf2\xea\xe5+\xe2\xf5\xee\xe4\xe0;+\xed\xe5+\xed\xe0\xf8\xeb\xee\xf1\xfc+\xf4\xee\xf0\xec\xfb+\xe4\xeb\xff+\xee\xf2\xef\xf0\xe0\xe2\xea\xe8;'))
2015-07-03 21:09:49,055 Trac[main] WARNING: [78.153.148.67] HTTPNotFound: 404 Not Found (Invalid URL encoding (was '/wiki/PhpBbAuthPlugin+++++++++++++++++++++++++++++++++++++++Result:+\xe8\xf1\xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xed+\xed\xe8\xea\xed\xe5\xe9\xec+"KennethCaf";+\xe7\xe0\xe2\xe5\xf0\xf8\xe5\xed\xee+\xef\xf0\xe8+\xef\xee\xef\xfb\xf2\xea\xe5+\xe2\xf5\xee\xe4\xe0;+\xed\xe5+\xed\xe0\xf8\xeb\xee\xf1\xfc+\xf4\xee\xf0\xec\xfb+\xe4\xeb\xff+\xee\xf2\xef\xf0\xe0\xe2\xea\xe8;'))
2015-07-03 21:09:50,420 Trac[main] ERROR: Exception caught while post-processing request:
Traceback (most recent call last):
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/Trac-1.0.6post2-py2.6.egg/trac/web/main.py", line 257, in dispatch
    self._post_process_request(req)
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/Trac-1.0.6post2-py2.6.egg/trac/web/main.py", line 370, in _post_process_request
    f.post_process_request(req, *(None,)*extra_arg_count)
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/TracVote-0.3.0-py2.6.egg/tracvote/__init__.py", line 389, in post_process_request
    if fnmatchcase(req.path_info, path) and \
  File "/srv/trac-hacks.org/pve/lib/python2.6/site-packages/Trac-1.0.6post2-py2.6.egg/trac/web/api.py", line 380, in path_info
    path_info=path_info))
HTTPNotFound: 404 Not Found (Invalid URL encoding (was '/wiki/phpbbauthplugin+++++++++++++++++++++++++++++++++++++++result:+\xe8\xf1\xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xed+\xed\xe8\xea\xed\xe5\xe9\xec+"kennethcaf";+\xe7\xe0\xe2\xe5\xf0\xf8\xe5\xed\xee+\xef\xf0\xe8+\xef\xee\xef\xfb\xf2\xea\xe5+\xe2\xf5\xee\xe4\xe0;+\xed\xe5+\xed\xe0\xf8\xeb\xee\xf1\xfc+\xf4\xee\xf0\xec\xfb+\xe4\xeb\xff+\xee\xf2\xef\xf0\xe0\xe2\xea\xe8;'))
2015-07-03 21:09:50,421 Trac[main] WARNING: [78.153.148.67] HTTPNotFound: 404 Not Found (Invalid URL encoding (was '/wiki/phpbbauthplugin+++++++++++++++++++++++++++++++++++++++result:+\xe8\xf1\xef\xee\xeb\xfc\xe7\xee\xe2\xe0\xed+\xed\xe8\xea\xed\xe5\xe9\xec+"kennethcaf";+\xe7\xe0\xe2\xe5\xf0\xf8\xe5\xed\xee+\xef\xf0\xe8+\xef\xee\xef\xfb\xf2\xea\xe5+\xe2\xf5\xee\xe4\xe0;+\xed\xe5+\xed\xe0\xf8\xeb\xee\xf1\xfc+\xf4\xee\xf0\xec\xfb+\xe4\xeb\xff+\xee\xf2\xef\xf0\xe0\xe2\xea\xe8;'))

I haven't investigated thoroughly. It's possible that _post_process_request in trac.web.main needs to handle the error.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

post_process_request is called with the Request object as the only argument after an exception is raised processing the request: trac:browser:tags/trac-1.0.6/trac/web/main.py@:257,261-263#L253. The exception is raised again when req.path_info decodes the path in VotePlugin's post_process_request.

After [14703] the logic in VotePlugin's post_process_request will be skipped when it is called after an exception is raised. Therefore the traceback should not be seen. Closing as a duplicate of #12105.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.