Modify

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12473 closed enhancement (fixed)

Prevent edits to pages in the TracGuide

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: TracHacksPlugin
Severity: normal Keywords:
Cc: Steffen Hoffmann Trac Release:

Description

The proposed change is to set all of the default pages to be read-only. Any existing user edits should be removed (or are they overwritten when during wiki upgrade?). We could add a notice to the pages that suggests instead making edits to the pages on t.e.o.

Attachments (0)

Change History (8)

comment:1 in reply to:  description Changed 9 years ago by Ryan J Ollos

Replying to rjollos:

or are they overwritten when during wiki upgrade?

Looks like they are overwritten. See WikiPageNames@3 and WikiPageNames@4.

comment:2 Changed 9 years ago by Ryan J Ollos

Status: newaccepted

comment:3 Changed 9 years ago by Ryan J Ollos

Component: TracHacksTracHacksPlugin
Type: defectenhancement

comment:4 Changed 9 years ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 15056:

3.0.0dev: Prevent edits to pages in the TracGuide

The behavior is implemented through the ReadonlyHelpPolicy
permission policy.

Fixes #12473.

comment:5 Changed 9 years ago by Ryan J Ollos

Summary: Prevent edits to default pagesPrevent edits to pages in the TracGuide

comment:6 Changed 9 years ago by Ryan J Ollos

Changes have been deployed to bobcat for testing.

comment:7 Changed 9 years ago by Ryan J Ollos

A regression introduced in [15056] will be fixed in #12613.

comment:8 Changed 8 years ago by Ryan J Ollos

I had forgotten to add permission_policies = ReadonlyHelpPolicy, ... when deploying to t-h.o. That change has now been made.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.