Modify

Opened 6 years ago

Closed 4 years ago

#12517 closed defect (wontfix)

Cannot see TeamCity Builds in timeline

Reported by: lukasz.matecki@… Owned by: Ryan J Ollos
Priority: normal Component: TeamcityPluginIntegration
Severity: normal Keywords: timeline teamcity
Cc: Trac Release: 1.0

Description

Hi, I've just downloaded and configured the TeamCity integration plugin. I can login to TeamCity, I can see TeamCity settings and I can do builds on the Builds page.

But I don't see builds history on the Timeline page (though there is TeamCity Builds checkbox present in the events types selection box).

My configuration:

  • Trac 1.1.5 (although it reports 1.0.4 as the package version)
  • Python 2.7 32-bit on Windows 7
  • Trac language is Polish
  • TeamCity 9.1.1
  • Plugin checked out from SVN:
    Revision: 13694
    Author: rjollos
    Date: 20 lutego 2014 03:41:33
    Message:
    Replaced deprecated `add_javascript` with `add_script`. Fixes #11589.
    ----
    Modified : /teamcitypluginintegration/trunk/teamcity/admin.py
    Modified : /teamcitypluginintegration/trunk/teamcity/timeline.py
    Modified : /teamcitypluginintegration/trunk/teamcity/web_ui.py
    
  • Timeline configuration in trac.ini:
    [timeline]
    abbreviated_messages = enabled
    changeset_collapse_events = enabled
    changeset_long_messages = disabled
    changeset_show_files = 50
    default_daysback = 30
    max_daysback = 90
    newticket_formatter = html
    ticket_show_component = enabled
    ticket_show_details = enabled
    

Attachments (1)

screen_2015-09-20T154512.png (11.4 KB) - added by anonymous 6 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 in reply to:  description Changed 6 years ago by Ryan J Ollos

Replying to lukasz.matecki@…:

  • Trac 1.1.5 (although it reports 1.0.4 as the package version)

Where do you see 1.0.4 reported? You likely have an installation problem. You may need to refresh your static resources: trac:wiki:TracUpgrade#a5.Refreshstaticresources.

For troubleshooting the problem with TeamcityPluginIntegration, enable logging: trac:TracTroubleshooting#ChecktheLogs.

Changed 6 years ago by anonymous

comment:2 Changed 6 years ago by lukasz.matecki@…

Replying to rjollos:

Where do you see 1.0.4 reported? You likely have an installation problem. You may need to refresh your static resources: trac:wiki:TracUpgrade#a5.Refreshstaticresources.

I see it on the About Trac page. I've taken a look at the trac:wiki:TracUpgrade#a5.Refreshstaticresources but I'm confused what to do with the content of the /deploy/path? Note: I'm using tracd as the server.

I also took a look at the debug output and don't see anything that looks like an error.

One more thing: I don't see the progress indicator when building (after looking into the deploy dir I can see a file called build_r.gif which I believe should be displayed during buidl next to the build target). Right now, when I'm pressing build, the checkbox disappears but the icon is still "OK" - shouldn't this show as the progress indicator?

comment:3 Changed 6 years ago by lukasz.matecki@…

I figured out the timeline problem - I had myself in the "by author" box (didn't realize that the builds are "done" by different user - ci server).

But when I click on the timeline entry, I'm getting the following error:

No handler matched request to /builds/_my_build_name_

comment:4 Changed 6 years ago by Ryan J Ollos

No need to worry about static resources if you are using tracd as a server.

You should probably reinstall Trac to fix the issue with the wrong version displaying on the About page. It sounds like a symptom of a more serious problem.

What does _my_build_name_ look like? The request is matched here: teamcitypluginintegration/trunk/teamcity/web_ui.py@13694:154-155#L136. We may need to adjust the regular expression if you are using something other than the default for [teamcity] builds.

Last edited 6 years ago by Ryan J Ollos (previous) (diff)

comment:5 Changed 6 years ago by lukasz.matecki@…

The exact message is this: No handler matched request to /builds/SimCos_Installer I've done nothing special in TeamCity - this was an auto - generated name for project "SimCos" and build "installer".

comment:6 Changed 6 years ago by Ryan J Ollos

It appears that the build ids have changed in TeamCity 8. It might be enough to modify the regex mentioned in comment:4:

-        return re.match('/builds/?(bt\d+)?$',req.path_info)
+       return re.match('/builds/\w+$',req.path_info)

or

-        return re.match('/builds/?(bt\d+)?$',req.path_info)
+       return re.match('/builds/.*$',req.path_info)

comment:7 Changed 6 years ago by lukasz.matecki@…

Changing to the second suggestion helps (clicking on the timeline entry jumps to the Builds page - I hope this was the expected behavior).

However, now the Builds button gives: No handler matched request to /builds

After a look at what is inside the egg, I think that the builds page doesn't work right. I can see stuff like real time progress display and the like but I can only see the following:

  • a checkbox next to build name and the build summary
  • after checking the checkbox and pressing Build Selected the checkbox disappears and no other activity is seen
  • refreshing the page only brings the checkbox back
  • after the entire build is complete, refreshing the page shows updated build status (date and time of the build)

Is this intended behavior?

comment:8 Changed 6 years ago by Ryan J Ollos

I have no idea what the intended behavior should be. The plugin looks to be a bit brittle with parsing the atom feed and there are some straightforward things that could be improved. I don't have access to TeamCity server to test. If you know of, or can make available, a test instance of TeamCity, I'd be willing to take a quick look at getting the plugin working. Feel free to contact me by email if there's something you can share but don't want to share publicly (see wiki:rjollos for contact info).

comment:9 Changed 6 years ago by lukasz.matecki@…

I have my TeamCity installed on my local computer and it is not so trivial for me to make it available outside my network.

But if you are willing to do some tests - it took me 10 minutes to install it and add a simple project - the free version can be downloaded form here: https://www.jetbrains.com/teamcity/download/. Be sure to use SYSTEM account (under Windows) - I had some issues to start the server if the server service was run under regular user account (but the builder worker service works OK under user account).

Let me know if it is outside your reach - I will try to setup my server for you.

comment:10 Changed 6 years ago by Ryan J Ollos

I'll try to take a look sometime this week.

comment:11 Changed 6 years ago by Ryan J Ollos

Owner: changed from Evgeniy Tetenchuk to Ryan J Ollos
Status: newaccepted

comment:12 Changed 4 years ago by Ryan J Ollos

Resolution: wontfix
Status: acceptedclosed

I guess I never got around to this one. Sorry about that.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.