Modify

Opened 6 years ago

Closed 6 years ago

#12531 closed defect (duplicate)

AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Reported by: anonymous Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a POST operation on /register, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'__FORM_TOKEN': u'105f2536121d526134b9897a',
 u'action': u'create',
 u'basic_token': u'test',
 u'email': u'singh.nagesh@cris.org.in',
 u'name': u'nagesh',
 u'password': u'nagesh1',
 u'password_confirm': u'',
 u'sentinel': u'',
 u'username': u'nageshkr'}

User agent: Mozilla/5.0 (Windows NT 6.3; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; McAfee; InfoPath.2; rv:11.0) like Gecko

System Information

Trac 1.2.dev0
Genshi 0.8 (without speedups)
pysqlite 2.4.1
Python 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
setuptools 18.3.2
SQLite 3.5.9
jQuery 1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Enabled Plugins

tracaccountmanager 0.5.dev0

Interface Customization

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 594, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 251, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\acct_mgr\register.py", line 445, in process_request
    acctmgr.validate_account(req, True)
  File "build\bdist.win32\egg\acct_mgr\api.py", line 387, in validate_account
    inspector.validate_registration(req)
  File "build\bdist.win32\egg\acct_mgr\register.py", line 148, in validate_registration
    for store_user in acctmgr.get_users():
  File "build\bdist.win32\egg\acct_mgr\api.py", line 249, in get_users
    users.extend(store.get_users())
  File "build\bdist.win32\egg\acct_mgr\db.py", line 33, in get_users
    db = self.env.get_db_cnx()
AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #11915.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.