Modify

Opened 3 years ago

Closed 17 months ago

Last modified 6 weeks ago

#12534 closed enhancement (fixed)

Allow Configuration admin panel to be disabled independent of User management admin panel

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Steffen Hoffmann Trac Release:

Description

The Configuration admin panel currently cannot be disabled without disabling the User management admin panel.

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by Ryan J Ollos

In 14910:

0.5dev: Configuration admin panel is independent of user admin panel

This allows the user to disable the Components they are not interested
in using. Additionally, some PEP-0008 and Trac coding style changes were
made. Refs #12534.

comment:2 Changed 3 years ago by Ryan J Ollos

In 14911:

0.5dev: Add a change log entry for [14910]

Refs #12534.

comment:3 Changed 3 years ago by Ryan J Ollos

Code review of the changes is much appreciated. I will leave the ticket open until the 0.5 release in accordance with the maintainer preference, though I'd really like to abandon that practice since it make ticket management very time consuming.

comment:4 Changed 3 years ago by Ryan J Ollos

ConfigurationAdminPanel can now be disabled with:

acct_mgr.admin.configurationadminpanel = disabled

in the [components] section of trac.ini.

comment:5 Changed 3 years ago by Ryan J Ollos

Summary: Allow Configuration admin panel to be disabled independent of User management mAllow Configuration admin panel to be disabled independent of User management admin panel

comment:6 Changed 17 months ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

comment:7 Changed 6 weeks ago by Ryan J Ollos

In 17056:

TracAccountManager 0.5dev: Fix regression in r14910

The function email_verified should be changed to only
return True/False, as implied by the function name.

Refs #12534.

comment:8 Changed 6 weeks ago by Ryan J Ollos

In 17057:

TracAccountManager 0.5dev: Extract function email_verification_token

email_verified now always returns True/False/None.

Refs #12534.

comment:9 Changed 6 weeks ago by Ryan J Ollos

In 17058:

TracAccountManager 0.5dev: Make style tweak to user page

Refs #12534.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.