Modify

Opened 6 years ago

Closed 6 years ago

#12598 closed defect (duplicate)

AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Reported by: sumendrasingh@… Owned by: Steffen Hoffmann
Priority: high Component: AccountManagerPlugin
Severity: major Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a GET operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'accounts', 'panel_id': u'users', 'path_info': None}

User agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36

System Information

Trac 1.2dev
Babel 0.9.6
Docutils 0.8.1
Genshi 0.6 (with speedups)
Mercurial 2.0.2
mod_python 3.3.1
MySQL server: "5.5.46-0ubuntu0.12.04.2", client: "5.5.46", thread-safe: 1
MySQLdb 1.2.3
Pygments 1.4
Python 2.7.3 (default, Jun 22 2015, 19:59:27)
[GCC 4.6.3]
setuptools 18.7
jQuery 1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Enabled Plugins

TracAccountManager 0.4.3
TracMercurial 1.0.0.7.dev0

Interface Customization

shared-htdocs
shared-templates
site-htdocs logo.png
site-templates

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.2dev-py2.7.egg/trac/web/main.py", line 594, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.2dev-py2.7.egg/trac/web/main.py", line 251, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.2dev-py2.7.egg/trac/admin/web_ui.py", line 108, in process_request
    provider.render_admin_panel(req, cat_id, panel_id, path_info)
  File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 204, in render_admin_panel
    return self._do_users(req)
  File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 449, in _do_users
    data['accounts'] = fetch_user_data(env, req)
  File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 73, in fetch_user_data
    authenticated=None).iteritems():
  File "build/bdist.linux-i686/egg/acct_mgr/model.py", line 123, in get_user_attribute
    db = _get_db(env, db)
  File "build/bdist.linux-i686/egg/acct_mgr/model.py", line 292, in _get_db
    return db or env.get_db_cnx()
AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #11915. After the next release of AccountManagerPlugin (#12569) there will be a version compatible with Trac 1.2dev.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.