Modify

Opened 6 years ago

Closed 6 years ago

#12610 closed defect (duplicate)

Hide rules not working with new installation

Reported by: rpshaw Owned by: Rob Guttman
Priority: normal Component: DynamicFieldsPlugin
Severity: major Keywords:
Cc: rpshaw@… Trac Release: 1.0

Description

Hello,

I just installed this DynamicFields into my installation to replace the deprectation CondFields plugin. To replicate CondFields behavior, I made extensive use of hide_always and show_when_type. This does not appear to work for two reasons:

  • All possible fields show up for all possible ticket types under the "Modify Fields" form
  • The properties table underneath the ticket title shows a small subset of the ticket fields (none of the custom fields except for the very last field in the list)

To prove that DynamicFields is installed and working, I tried to utilize the invalid_if rule, and that works. I am using Trac 1.0 and the trunk version of DynamicFields. This issue shows up on both Firefox 38.3.0 and Internet Explorer 11.

Since my setup includes a lot of other plugins, I've included my [components] section from trac.ini. Is there any known incompatibility between DynamicFields and any of the other active plugins?

Thanks, Ryan

[components]
announcer.* = enabled
announcer.distributors.mail.emaildistributor = disabled
color.* = enabled
condfields.* = disabled
customfieldadmin.api.customfields = enabled
customfieldadmin.customfieldadmin.customfieldadminpage = enabled
defaultcc.* = enabled
defaultcc.admin.defaultccadmin = enabled
defaultcc.main.ticketdefaultcc = enabled
dynfields.* = enabled
includemacro.macros.includemacro = enabled
iniadmin.iniadmin.iniadminplugin = enabled
navadd.* = enabled
quiet.* = enabled
sensitivetickets.sensitivetickets.sensitiveticketspolicy = enabled
simpleticket.* = enabled
ticketcharts.ticketcharts.ticketchartmacro = disabled
ticketdep.macro.ticketblockees = enabled
ticketdep.macro.ticketblockers = enabled
ticketdep.web_ui.ticketdepmodule = enabled
ticketstats.* = enabled
ticketstats.macro.ticketstatsmacro = disabled
ticketstats.ticketstats.ticketstatsplugin = disabled
tracadvparseargs.parseargs.parseargstestmacro = enabled
tracdragdrop.* = enabled
tracinclude.* = enabled
tracnav.tracnav.tracnav = enabled
tracopt.perm.config_perm_provider.extrapermissionsprovider = enabled
tracopt.ticket.clone.ticketclonebutton = enabled
tracopt.ticket.deleter = enabled
tracopt.versioncontrol.svn.svn_fs.subversionconnector = enabled
tracopt.versioncontrol.svn.svn_prop.subversionmergepropertydiffrenderer = enabled
tracopt.versioncontrol.svn.svn_prop.subversionmergepropertyrenderer = enabled
tracopt.versioncontrol.svn.svn_prop.subversionpropertyrenderer = enabled
tracrpc.* = enabled
tractags.api.tagengine = enabled
tractags.api.tagsystem = enabled
tractags.macros.listtaggedmacro = enabled
tractags.macros.tagcloudmacro = enabled
tractags.macros.tagmacros = enabled
tractags.model.tagmodelprovider = enabled
tractags.ticket.tickettagprovider = enabled
tractags.ticket.tickettags = enabled
tractags.web_ui.tagrequesthandler = enabled
tractags.web_ui.tagsmodule = enabled
tractags.web_ui.tagsuserinterface = enabled
tractags.web_ui.tagswikimodule = enabled
tractags.web_ui.tagtemplateprovider = enabled
tractags.wiki.tagwikisyntaxprovider = enabled
tractags.wiki.wikitaginterface = enabled
tractags.wiki.wikitagprovider = enabled
tractags.wiki.wikitags = enabled
tractoc.macro.tocmacro = enabled
tracwysiwyg.templateprovider = enabled
tracwysiwyg.wysiwygwikifilter = enabled

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by rpshaw

Resolution: duplicate
Status: newclosed

Duplicate of #12609

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Rob Guttman.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.