Modify

Opened 7 years ago

Closed 7 years ago

#12692 closed defect (duplicate)

IOError: 2 没有那个文件或目录

Reported by: bsxz0604@… Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'__FORM_TOKEN': u'b558cc746fb0d7f85ba59af4',
 u'add': u'\u6dfb\u52a0',
 'cat_id': u'accounts',
 u'email': u'nic.li@wgz001.com',
 u'name': u'test',
 'panel_id': u'users',
 u'password': u'test',
 u'password_confirm': u'test',
 'path_info': None,
 u'username': u'test'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

System Information

Trac 1.0.10
Babel 0.9.4
Genshi 0.7 (without speedups)
MySQL server: "5.5.48", client: "5.1.54", thread-safe: 1
MySQLdb 1.2.3c1
Pygments 1.1.1
Python 2.6.6 (r266:84292, Jul 23 2015, 15:22:56)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-11)]
pytz 2010h
setuptools 0.6
jQuery 1.7.2
jQuery UI 1.8.21
jQuery Timepicker 1.0.1

Enabled Plugins

TracAccountManager 0.5dev
TracAutocompleteUsersPlugin 0.4.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Trac-1.0.10-py2.6.egg/trac/web/main.py", line 554, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.10-py2.6.egg/trac/web/main.py", line 247, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.10-py2.6.egg/trac/admin/web_ui.py", line 119, in process_request
    path_info)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/admin.py", line 219, in render_admin_panel
    return self._do_users(req)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/admin.py", line 621, in _do_users
    data['acctmgr'] = self._do_add(req)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/admin.py", line 236, in _do_add
    acctmgr.validate_account(req, True)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/api.py", line 390, in validate_account
    self._create_user(req)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/api.py", line 415, in _create_user
    overwrite=False)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/api.py", line 276, in set_password
    overwrite)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/htfile.py", line 53, in set_password
    overwrite)
  File "/usr/lib/python2.6/site-packages/TracAccountManager-0.5dev-py2.6.egg/acct_mgr/htfile.py", line 161, in _update_file
    f = open(filename, 'w')
IOError: [Errno 2] 没有那个文件或目录: ''

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #9623.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.