Modify

Opened 6 years ago

Closed 5 years ago

#12768 closed defect (duplicate)

After password reset, password has to be changed twice

Reported by: HMuentinga Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

How to reproduce

  1. Reset password via trac/reset_password
  2. Log in with temporary password
  3. Change password
  4. Log out
  5. Try to log in again

Expected behaviour

New password should be accepted.

Observed behaviour

New password is not accepted, temporary one sent via e-mail still works. Changing the password a second really changes the password, everything works from then on.

More info

Attachments (0)

Change History (5)

comment:2 Changed 6 years ago by Ryan J Ollos

Reporter: changed from anonymous to HMuentinga

Might be related to #11869. Will need to see your [account-manager] section of trac.ini.

comment:3 Changed 6 years ago by HMuentinga

Sure, here it is (sans sensitive information):

[account-manager]
account_changes_notify_addresses = XXX
force_passwd_change = true
generated_password_length = 8
hash_method = HtPasswdHashMethod
htpasswd_file = /path/to/trac.passwd
htpasswd_hash_type = sha512
notify_actions = change
password_store = HtPasswdStore
refresh_passwd = True

comment:4 Changed 5 years ago by Ryan J Ollos

Owner: Steffen Hoffmann deleted

comment:5 Changed 5 years ago by Ryan J Ollos

Owner: set to Ryan J Ollos
Status: newaccepted

comment:6 Changed 5 years ago by Ryan J Ollos

Resolution: duplicate
Status: acceptedclosed

I cannot reproduce with your configuration. The issue might have been fixed in #12228. Let me know whether you can reproduce after installing the latest TracAccountManager trunk.

For now, I'm assuming this a duplicate of #12228.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.