Modify

Opened 6 years ago

Closed 6 years ago

#12848 closed defect (duplicate)

IOError: [Errno 2] No such file or directory: ''

Reported by: firehare Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{u'__FORM_TOKEN': u'6378217b857f8012f8303f26',
 u'add': u'\u6dfb\u52a0',
 'cat_id': u'accounts',
 u'email': u'ge_qinglong@nec.cn',
 u'name': u'',
 'panel_id': u'users',
 u'password': u'gql123!@#',
 u'password_confirm': u'gql123!@#',
 'path_info': None,
 u'username': u'geqinglong'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36

System Information

Trac 1.0.12
Babel 1.3
Docutils 0.11
Genshi 0.6 (with speedups)
GIT 1.8.3.2
mod_python 3.3.1
psycopg2 2.4.5
Pygments 1.6
Python 2.7.5+ (default, Feb 27 2014, 19:40:54)
[GCC 4.8.1]
pytz 2014.2
setuptools 0.6
Subversion 1.7.9 (r1462340)
jQuery 1.7.2
jQuery UI 1.8.21
jQuery Timepicker 1.0.1

Enabled Plugins

IniAdmin 0.3
SvnAuthzAdminPlugin 1.0dev
TracAccountManager 0.4.4
TracWysiwyg 0.12.0.5

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.12-py2.7.egg/trac/web/main.py", line 562, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.12-py2.7.egg/trac/web/main.py", line 249, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.12-py2.7.egg/trac/admin/web_ui.py", line 119, in process_request
    path_info)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/admin.py", line 204, in render_admin_panel
    return self._do_users(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/admin.py", line 348, in _do_users
    acctmgr.validate_registration(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/api.py", line 367, in validate_registration
    self.set_password(username, req.args.get('password'))
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/api.py", line 245, in set_password
    if store.set_password(user, password, old_password):
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/htfile.py", line 55, in set_password
    self.userline(user, password))
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.4-py2.7.egg/acct_mgr/htfile.py", line 158, in _update_file
    f = open(filename, 'w')
IOError: [Errno 2] No such file or directory: ''

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #10643.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.