Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12857 closed defect (fixed)

Error: Missing PDF file

Reported by: Ryan J Ollos Owned by: tkob-trac
Priority: normal Component: PdfPreviewPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description (last modified by Ryan J Ollos)

On viewing a PDF attached to WikiStart, I get the following error:

PDF.js v1.4.20 (build: b15f335)
Message: Missing PDF "http://localhost:8000/proj-1.0/chrome/pdfpreview/web/compressed.tracemonkey-pldi-09.pdf".

Attachments (3)

Screen Shot 2016-08-27 at 13.41.29.png (218.4 KB) - added by Ryan J Ollos 6 years ago.
tracpdfpreview-t12857.diff (1.2 KB) - added by Ryan J Ollos 6 years ago.
fixquery.diff (605 bytes) - added by tkob-trac 6 years ago.

Download all attachments as: .zip

Change History (13)

Changed 6 years ago by Ryan J Ollos

comment:1 Changed 6 years ago by Ryan J Ollos

Description: modified (diff)

Changed 6 years ago by Ryan J Ollos

Attachment: tracpdfpreview-t12857.diff added

comment:2 Changed 6 years ago by Ryan J Ollos

Unrelated: tracpdfpreview-t12857.diff removes some unused code and makes a PEP8 compliant change.

comment:3 Changed 6 years ago by tkob-trac

Status: newaccepted

Thank you for the report, but I cannot reproduce the problem. Could you tell me more about your setup? e.g. Trac version, browser...

I use Trac 1.0 on the server and Firefox 45.0.2, Edge and IE 11 on Windows client.

By the way, compressed.tracemonkey-pldi-09.pdf is an example PDF file which is originally shipped with PDF.js and removed from PdfPreviewPlugin.

Changed 6 years ago by tkob-trac

Attachment: fixquery.diff added

comment:4 Changed 6 years ago by tkob-trac

I think I found an error which may solve the problem.

Probably this patch should be committed anyway, but could you see if this solves your problem?

comment:5 Changed 6 years ago by Ryan J Ollos

fixquery.diff resolves the issue. I've tested with the latest Trac 1.0-stable and TracStandalone.

comment:6 Changed 6 years ago by tkob-trac

Resolution: fixed
Status: acceptedclosed

In 15738:

Fix incomplete quey, closes #12857

comment:7 Changed 6 years ago by tkob-trac

Thank you for taking your time!

comment:8 Changed 6 years ago by Ryan J Ollos

Would you mind if I committed the patch that removes the unused import and unnecessary initializer code?

comment:9 Changed 6 years ago by tkob-trac

In 15791:

Remove unused code. patch by rjollos. refs #12857

comment:10 Changed 6 years ago by tkob-trac

I forgot about your patch. Thank you.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain tkob-trac.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.