Opened 16 years ago

Closed 12 years ago

Last modified 14 months ago

#13 closed defect (worksforme)

footnotes don't get added to the list

Reported by: bencollins@… Owned by: Alec Thomas
Priority: normal Component: FootNoteMacro
Severity: major Keywords:
Cc: Trac Release: 0.11

Description (last modified by Alec Thomas)

I have rev. 29 installed in ~/wiki-macros. However, when I try to use in in a wiki page, I only get a little "1" superscripted, and no footnotes at the bottom (even though I have [[FootNote]] at the bottom).

Attachments (0)

Change History (25)

comment:1 Changed 16 years ago by Alec Thomas

Status: newassigned

What is the exact form you are using to call FootNote?

comment:2 Changed 16 years ago by bencollins@…

... some other wiki content ...

  • item in list[[FootNote(blah blah blah)]]

... rest of content


comment:3 Changed 16 years ago by Alec Thomas

That is quite odd. As you can see below, an exact copy of your content works fine here. Perhaps try looking at the source, see if it is actually generating the output but not displaying it? All the styles are inline so there shouldn't be any external dependencies. Are you running under CGI or mod_python? I use CGI so perhaps it is some difference there.

... some other wiki content ...

  • item in list1

... rest of content

  1. 1. blah blah blah

comment:4 Changed 16 years ago by Alec Thomas

Resolution: worksforme
Status: assignedclosed

comment:5 Changed 16 years ago by wrs

Severity: majornormal

I also have this issue, seems the footnotes are not being set.

If I have more than one footnote on the page, they are all called '1'.

I get the small HR at the bottom of the page, but no footnotes.

Im using the code

Text [[FootNote(This is my first footnote)]]

Text [[FootNote(This is my second footnote)]]


This is all on FreeBSD4-STABLE, Apache 2.0.53, Perl 5.8.6, Python 2.4, Trac 0.8 and Rev29

comment:6 Changed 16 years ago by wrs

Resolution: worksforme
Severity: normalmajor
Status: closedreopened


comment:7 Changed 16 years ago by Alec Thomas

Hmm, can you try this on 0.8.1?

comment:8 Changed 16 years ago by Alec Thomas

Description: modified (diff)

comment:9 Changed 16 years ago by wrs

Sure, deinstalled 0.8 then installed 0.8.1 but the same problem occurs :/

This is a really nice macro ( i've seen it on other sites ), I hope we can figure out why it isn't updating the footnotes :)

I've noticed that this site has the same problem.

Whats your python version and OS ?

comment:10 Changed 16 years ago by Alec Thomas

I am running Slackware current, python 2.4. You're not using mod_python by any chance? If so, it could be a problem with the global variables not being re-initialized due to the persistent nature of mod_python.

comment:11 Changed 16 years ago by wrs

Nope, not that I am aware of:

[root@titan ~]# pkg_info | grep py
clearsilver-python-0.9.13_1 A fast, powerful, and language-neutral template system
py24-PySQLite-1.0.1 A DB-API v2 Python library for the SQLite 2 embedded SQL en
python-2.4_1        An interpreted object-oriented programming language
subversion-python-1.1.3 Version control system


comment:12 Changed 16 years ago by Alec Thomas

Hmmm, I don't know what to do really, given that I can't replicatite it... :(

You've checked the logs I assume? Perhaps the next step is to place some debugging output in the macro and see what is doing what.

comment:13 Changed 16 years ago by wrs

Which logs? My apaches virtualhost logs have nothing of interest. Is there somewhere else I should be looking?

Ive never used python before, i've tried adding a couple of out.write()s to the source but havn't noticed anything odd.. but, i dont know what im doing :)

comment:14 Changed 15 years ago by…

Same Problem for me. I'm using Linux 9.2 and the Trac-Version is 0.8.1. Any Ideas?

comment:15 Changed 15 years ago by Marius Huysamen


I have the same problem. The FootNotes get added to the array, but they don't persist between invocations.

Software: Apache 2.0.47 Trac 0.8.4 (CGI) Python 2.3

comment:16 Changed 15 years ago by Marius Huysamen

Got it working'''

Placing the FootNoteMacro into the site-wide wikimacros2 directory instead of the repository local3 wiki-macros directory did the trick.

  1. 2. Where Trac's code is installed, mine is in /usr/lib/python2.3/site-packages/trac/wikimacros
  2. 3. Where you've created your trac env with trac-admin initenv

comment:17 Changed 15 years ago by anpaza@…

Some research shows that the footnotes[] sequence is empty on every macro invocation if it's copied into the non-systemwide storage (this explain both multiple 1 marks for multiple footnotes, and also explains that there's nothing below the footnote rule), like noted. This means that Trac unloads the local macros while keeping loaded all global macros.

I think that this is worth to be noted somewhere in installation instructions, since it seems there's a lot of people confused by this.

comment:18 Changed 15 years ago by Alec Thomas

Okay, thanks for investigating this guys. I've added a note about this on the FootNoteMacro page.

I can't really see a work-around for this unfortunately.

comment:19 Changed 15 years ago by Alec Thomas

version: stable

comment:20 Changed 15 years ago by Alec Thomas

Resolution: fixed
Status: reopenedclosed

This issue was fixed in [118], for trunk. About time, some might say.

comment:21 Changed 13 years ago by anonymous

Resolution: fixed
Status: closedreopened
Trac Release: 0.10

This macro is broken again in Trac 0.10.3 on Windows with TracD - same problem as decribed originally (numbers but no footnotes), regardless of which wiki-macros folder is used. I tried the downloaded ZIP and the trunk.

Is the one you are using on this site different, or has Trac changed to fix it (you are running (0.10.5dev)?

comment:22 Changed 13 years ago by Alec Thomas

This site is running the same version, and nothing in Trac has changed. Try enabling debug logging and see if anything useful shows up.

comment:23 Changed 13 years ago by anonymous

there is no wiki-macros dir under trac in 0.10 for python2.4. not in my setup, anyway.

comment:24 Changed 12 years ago by anonymous

Just an observation but I found that when I unzipped the download file on Solaris the file in the 0.9 subdirectory was called

Unsurprisingly, only when I renamed the file to the did things work as documented when using the macro name FootNote.

Looks like a problem when preparing the download file.

comment:25 Changed 12 years ago by anonymous

Resolution: worksforme
Status: reopenedclosed
Trac Release: 0.100.11

I just installed FootNoteMacro on my trac 0.11 environment and got it running as soon as I enable it. (Fedora Core 9 - PHP 5.2.6-2.fc9 - wsgi )

My step by step:

svn checkout
easy_install footnotemacro/0.11/

On trac.ini

footnotemacro.macro.footnotemacro = enabled


Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Alec Thomas.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.