Modify

Opened 5 years ago

Closed 5 years ago

#13059 closed defect (duplicate)

Tickets randomly throws an error to gui when adding a "blocking" or "blocked by" for a ticket

Reported by: joseph.garcia@… Owned by: Ryan J Ollos
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I can't find a pattern as to why it will display this on the gui, but the message will pop up on a random ticket after a "blocking" or "blocked by" is added to a ticket and submit is pressed. It will still added the "blocking" or "blocked by" to the ticket though.

This is the error:

Trac detected an internal error:
AttributeError: 'NoneType' object has no attribute 'split'

This is what appears in the log file.

AttributeError: 'NoneType' object has no attribute 'split'
2017-01-27 05:37:47,077 Trac[main] ERROR: Internal Server Error: <RequestWithSession "POST '/ticket/1358'">, referrer 'https://<myserver>/e/ticket/1358'
Traceback (most recent call last):
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/web/main.py", line 562, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/web/main.py", line 249, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/web_ui.py", line 181, in process_request
    return self._process_ticket_request(req)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/web_ui.py", line 623, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/web_ui.py", line 1355, in _do_save
    replyto=req.args.get('replyto'))
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/model.py", line 369, in save_changes
    listener.ticket_changed(self, comment, author, old_values)
  File "/opt/trac-projects/e/plugins/TracMasterTickets-3.0.1-py2.6.egg/mastertickets/api.py", line 111, in ticket_changed
    links.save(author, comment, tkt.time_changed, db)
  File "/opt/trac-projects/e/plugins/TracMasterTickets-3.0.1-py2.6.egg/mastertickets/model.py", line 67, in save
    new_value = [x.strip() for x in old_value.split(',') if x.strip()]
AttributeError: 'NoneType' object has no attribute 'split'
2017-01-27 05:37:47,077 Trac[main] ERROR: Internal Server Error: <RequestWithSession "POST '/ticket/1358'">, referrer 'https://<myserver>/e/ticket/1358'
Traceback (most recent call last):
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/web/main.py", line 562, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/web/main.py", line 249, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/web_ui.py", line 181, in process_request
    return self._process_ticket_request(req)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/web_ui.py", line 623, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/web_ui.py", line 1355, in _do_save
    replyto=req.args.get('replyto'))
  File "/usr/local/lib64/python2.6/site-packages/Trac-1.0.11-py2.6.egg/trac/ticket/model.py", line 369, in save_changes
    listener.ticket_changed(self, comment, author, old_values)
  File "/opt/trac-projects/e/plugins/TracMasterTickets-3.0.1-py2.6.egg/mastertickets/api.py", line 111, in ticket_changed
    links.save(author, comment, tkt.time_changed, db)
  File "/opt/trac-projects/e/plugins/TracMasterTickets-3.0.1-py2.6.egg/mastertickets/model.py", line 67, in save
    new_value = [x.strip() for x in old_value.split(',') if x.strip()]
AttributeError: 'NoneType' object has no attribute 'split'

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Please upgrade to 4.0.0dev. Duplicate of #12180.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.