Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13121 closed defect (duplicate)

Unknown operator 'may_set_owner'

Reported by: Andrew Schulman Owned by: Jun Omae
Priority: normal Component: TracWorkflowAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description

TracWorkflowAdmin 0.12.0.4, r16358, in Trac 1.2. When I visit admin/ticket/workflowadmin, below the table I get a yellow error box with the message:

Line 6: Unknown operator 'may_set_owner'

And the graph doesn't appear, although I have the graphviz plugin (1.0.0.9dev) installed and have verified that it's working in other parts of our wiki. If I click on Update, it returns with no change. See the screenshot.

Attachments (1)

workflowadmin.png (45.5 KB) - added by Andrew Schulman 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by Andrew Schulman

Attachment: workflowadmin.png added

comment:1 Changed 5 years ago by Ryan J Ollos

Appears it should have been fixed in r16032. What is your [ticket-admin] operations option set to in trac.ini?

comment:2 Changed 5 years ago by Andrew Schulman

Hm. In trac.ini I have:

[ticket-workflow]
create_and_assign.operations = may_set_owner

So that seems to be the trouble. If I change the value to set_owner, the problem goes away.

But I don't have a [ticket-admin] section. Didn't know I needed it, and I can't find any documentation of it. Can you suggest a value for operations?

comment:3 Changed 5 years ago by Ryan J Ollos

You can find documentation for [ticket-admin] on TracIni in your Trac installation. You can see values for your Trac installation on the /about page when you have TRAC_ADMIN or CONFIG_VIEW. If you haven't set a value then you'll be using the default, which should be fine.

comment:4 Changed 5 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #12933.

If you don't need to configure [workflow-admin] operations, remove the option from your trac.ini. Otherwise, append may_set_owner to the option.

And the graph doesn't appear, although I have the graphviz plugin (1.0.0.9dev) installed and have verified that it's working in other parts of our wiki. If I click on Update, it returns with no change. See the screenshot.

The graph isn't rendered due to errors of the workflow.

Last edited 5 years ago by Jun Omae (previous) (diff)

comment:5 Changed 5 years ago by Ryan J Ollos

Oh, right. Sorry I mistakenly said [ticket-admin] rather then [workflow-admin].

Last edited 5 years ago by Ryan J Ollos (previous) (diff)

comment:6 Changed 5 years ago by anonymous

Got it. I reset [workflow-admin] operations to its default, and the problem is fixed. Thank you for your help.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.