Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13168 closed defect (duplicate)

Uncaught TypeError in Chrome browser

Reported by: anonymous Owned by: Tetsuya Morimoto
Priority: normal Component: AutocompleteUsersPlugin
Severity: normal Keywords: jquery
Cc: Trac Release: 1.2

Description

Seems to affect Chrome (Version 58.0.3029.81 (64-bit)) and not FireFox, and causes plugin to not work as expected. Some googling seems to suggest that $.browser was removed in 1.9, and maybe firefox is a bit more forgiving.

autocomplete.js:96 Uncaught TypeError: Cannot read property 'opera' of undefined
    at new $.Autocompleter (autocomplete.js:96)
    at HTMLInputElement.<anonymous> (autocomplete.js:39)
    at Function.each (jquery.js:2)
    at m.fn.init.each (jquery.js:2)
    at m.fn.init.autocomplete (autocomplete.js:38)
    at HTMLDocument.<anonymous> (autocomplete_newticket.js:6)
    at j (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at Function.ready (jquery.js:2)
    at HTMLDocument.J (jquery.js:2)

I'm using the version of AutoCompleteUsers obtained from this URL:

https://trac-hacks.org/browser/autocompleteusersplugin?rev=16561&format=zip

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #12664. Install from trunk to get the fix.

comment:2 Changed 2 years ago by Ryan J Ollos

If you can confirm the fix, that will give more confidence to tagging the trunk as a release.

comment:3 Changed 2 years ago by anonymous

Hi - I'm so sorry for this, but it appears to be an issue with me needing to clear my browser cache. Can confirm that it works as expected in trunk for me.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Tetsuya Morimoto.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.