Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13208 closed defect (cantfix)

Error on upgrade operation

Reported by: anonymous Owned by: Jun Omae
Priority: normal Component: TracBackLinkPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description

Hi,

With Trac 1.2.1, after installing and enabling TrackBackLinkPlugin, i run the command

trac-admin $ENV upgrade

Then i get the following error :

Error: AttributeError: 'sqlite3.Connection' object has no attribute 'get_table_names'

Any idea or fix ?

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Jun Omae

Resolution: cantfix
Status: newclosed

Cannot reproduce it with Trac 1.2.1 and fresh Trac environment.

get_table_names is available since 1.1.2dev, introduced in trac:r12712. Your Trac is not 1.2.1.

comment:2 Changed 3 years ago by Jun Omae

In 16655:

TracBackLinkPlugin/1.0.6: requires Trac 1.0.2 or later (refs #13208)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.