Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13225 closed defect (fixed)

Links to milestone do not work

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: MultiProjectBacklogPlugin
Severity: normal Keywords: backlog milestone
Cc: jminto@… Trac Release: 1.2

Description

Links to milestones on the right of http://../trac/mpbacklog do not work. Links look like this:

http://10.0.0.12/trac/mpbacklog/milestone/Sprint%207%2F14%2F17?mp_proj=

Clicking on the link reveals a "Not Found" error message from the webserver. Attached, please find screenshots that identify where the malformed URLs are located and the resultant page when one of them are clicked.

trac instance is configured with deployed files. No where in the instance, nor the public html tree may be found the path "~/mpbacklog/milestone/". Current directories appear:

  • public_html/htdocs/mpbacklog/
    • css
    • js
  • .python-eggs/MultiProjectBacklog-0.4.0.dev0-py2.7.egg-tmp/multiprojectbacklog/htdocs/
    • css
    • js

No errors or warnings appear in the trac debug log when DEBUG is set. No errors or warnings appear in the Apache error log. Apache access log reports successful query of URL that does not exist.

Attachments (2)

backlog01.png (229.5 KB) - added by jminto@… 2 years ago.
mpbacklog plugin ui screenshot with milestones (sprint) URLs circled
backlog02.png (68.7 KB) - added by jminto@… 2 years ago.
Webserver error message when backlog plugin milestone (sprint) hyperlinks are traversed

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by jminto@…

Attachment: backlog01.png added

mpbacklog plugin ui screenshot with milestones (sprint) URLs circled

Changed 2 years ago by jminto@…

Attachment: backlog02.png added

Webserver error message when backlog plugin milestone (sprint) hyperlinks are traversed

comment:1 Changed 2 years ago by Ryan J Ollos

Owner: changed from Cinc-th to Ryan J Ollos
Status: newaccepted

comment:2 Changed 2 years ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 16700:

MultiProjectBacklog 0.4.0dev: Fix incorrect encoding of milestone name

Fixes #13225.

comment:3 Changed 2 years ago by Ryan J Ollos

Please reopen if there are any remaining issues after r16700.

comment:4 Changed 2 years ago by jminto@…

Fantastic - confirmed working and it's great.

comment:5 Changed 2 years ago by Ryan J Ollos

Thanks. I was a bit unsure about the mp_proj parameter, and was seeing some strange behavior when used with multi-project, but it's likely I just don't understand the intended behavior.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.