Modify

Opened 9 months ago

Closed 9 months ago

#13244 closed defect (worksforme)

Static Assets Not Included on Page

Reported by: grimmdude Owned by: Olli Kallioinen
Priority: normal Component: MultiSelectFieldPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I'm running into an issue where most of the time this plugin works flawlessly, however sometimes when loading a ticket the css/js assets associated with this plugin simply do not output on the page, thus the multiselect field doesn't load or get styled correctly. Any idea what would be causing this?

Attachments (0)

Change History (7)

comment:1 in reply to:  description Changed 9 months ago by Ryan J Ollos

Replying to grimmdude:

... sometimes when loading a ticket the css/js assets associated with this plugin simply do not output on the page, ...

When viewing the page source, do you see the links to the assets, or are the links missing? If the links are present, is it just the assets that fail to be found at the URL?

comment:2 Changed 9 months ago by Ryan J Ollos

In 16716:

TracMultiSelectField 1.0.2: Tidy up codebase

Refs #13244.

comment:3 Changed 9 months ago by Ryan J Ollos

Also, were you running r16625 (1.0.2dev)? I bumped the version now so you can be sure you are running the latest (1.0.2).

comment:4 Changed 9 months ago by anonymous

Thanks for your quick response. The asset link is actually not being output in the source HTML. This is only happening like 1/20 requests.

I just updated to the latest version of the plugin and I'm still seeing this happening. It may be relevant to note that I'm running two environments on a server using apache WSGI; both environments have this issue. Plugin is globally installed with easy_install and assets statically deployed separately for each environment. Thanks,

-Garrett

comment:5 Changed 9 months ago by Ryan J Ollos

Are there any exceptions in the browser console when the issue is seen? I'm unsure what the issue could be. The plugin is very simple and should add the assets to the page when the path starts with /ticket, /newticket or /simpleticket: multiselectfieldplugin/1.0/multiselectfield/filter.py@16716:43#L13.

comment:6 Changed 9 months ago by anonymous

There are no errors in the browser console, the only indication that it's not working is the multi select field is plain text, ie JS didn't load it. I'm thinking it's probably not related to this plugin and most likely something to do with multiple envs and how I had it setup. I just ended up moving my second environment to a different ec2 instance and all is good.

My original setup seemed correct as far as I could tell, but this issue started creeping up once I added a second env so it must have been related. Thank you,

-Garrett

comment:7 Changed 9 months ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

Thanks for the update. Let me know if the issue reoccurs.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Olli Kallioinen.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.