Modify

Opened 5 years ago

Closed 5 years ago

#13249 closed defect (duplicate)

AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Reported by: tracAdmin Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a GET operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'accounts', 'panel_id': u'users', 'path_info': None}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0

System Information

Trac 1.2
Babel 2.4.0 (translations unavailable)
Docutils 0.13.1
Genshi 0.7 (with speedups)
mod_wsgi 4.5.13 (WSGIProcessGroup WSGIApplicationGroup trac.sample.com.au)
psycopg2 2.7.3
Pygments 2.2.0
Python 2.7.13 (default, Jun 26 2017, 10:20:05)
[GCC 7.1.1 20170622 (Red Hat 7.1.1-3)]
pytz 2017.2
setuptools 36.2.4
jQuery 1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Enabled Plugins

TracAccountManager 0.4.4

Interface Customization

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 613, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 253, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/site-packages/trac/admin/web_ui.py", line 108, in process_request
    provider.render_admin_panel(req, cat_id, panel_id, path_info)
  File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 204, in render_admin_panel
    return self._do_users(req)
  File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 449, in _do_users
    data['accounts'] = fetch_user_data(env, req)
  File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 73, in fetch_user_data
    authenticated=None).iteritems():
  File "build/bdist.linux-x86_64/egg/acct_mgr/model.py", line 123, in get_user_attribute
    db = _get_db(env, db)
  File "build/bdist.linux-x86_64/egg/acct_mgr/model.py", line 292, in _get_db
    return db or env.get_db_cnx()
AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #11915.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.