Modify

Opened 3 years ago

Closed 3 years ago

#13284 closed enhancement (duplicate)

Use configuration options to allow for SELECT list for Topic/Conclusion and all UI labels

Reported by: Richard Lyders Owned by: Cauly
Priority: normal Component: AccreditationPlugin
Severity: normal Keywords:
Cc: richard@… Trac Release: 1.2

Description

I've added the following features to the accreditation plugin and attached the new code. (If there is a preferred way to propose new code for plugins, please let me know. Thanks)

  1. All UI text is now configured via options in trac.ini
  2. Both the topic and conclusion INPUT elements can now be configured as a SELECT list of OPTIONS

Below is a sample of what the new configurable options could be in the trac.ini

[accreditation]
created_comment_label = Approvers defined for:
updated_comment_label = Response from approver:
webui_participants_title = Approver(s)
webui_table_comments_title = Comments/Results
webui_table_conclusion_options = Untested,Approved,Inconclusive,Rejected
webui_table_conclusion_title = Approve/Reject
webui_table_participant_title = Approver
webui_topic_options = DEV-test,INT2-test,PROD-verify
webui_topic_title = Type
webui_wrapper_title = Approvals

Attachments (1)

Accreditation.py (10.6 KB) - added by Richard Lyders 3 years ago.
Enhancements to Accreditation.py: configurable labels and configurable SELECT list of OPTIONs for topic and conclusion fields

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by Richard Lyders

Attachment: Accreditation.py added

Enhancements to Accreditation.py: configurable labels and configurable SELECT list of OPTIONs for topic and conclusion fields

comment:1 Changed 3 years ago by anonymous

Thank you. I will check and merge in a few days.

comment:2 Changed 3 years ago by Richard Lyders

PS: If you don't configure the SELECT list of OPTIONs for the topic or conclusion fields, then the default is to simply show the original INPUT field so that existing installations should not be not affected by these new features.

PSS: All the default values for the new configurable label options should match the original values so existing installations should not be affected.

comment:3 Changed 3 years ago by Richard Lyders

Resolution: duplicate
Status: newclosed

This enhancement can be closed as a duplicate of enhancement #13289 considering I've attached a complete unified patch to #13289 with this and all other changes I've implemented.

Complete patch attached with all changes to date ... (the attachment description erroneously calls it a "complete path".

Thanks again for this plugin. We are getting some good use out of it.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Cauly.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.