Modify

Opened 3 years ago

Closed 3 years ago

#13288 closed enhancement (duplicate)

Redirect back to the accreditation wrapper after each change to keep user focused on the accreditations

Reported by: Richard Lyders Owned by: Cauly
Priority: normal Component: AccreditationPlugin
Severity: normal Keywords:
Cc: Richard@… Trac Release: 1.2

Description

This is a small tweak to keep the user's focus on the accreditation area of the ticket form and avoid the need for the user to keep scrolling down when several changes are being made to the accreditations. Since this now displays the HTML ID of the accreditation wrapper, I thought it helpful to make the HTML ID of the main container a configurable item so as to be able to align this reference with whatever might make most sense to the user.

Specific changes:

  1. webui_wrapper: new config entry for the ID of the HTML container for accreditations
  2. appended all redirects with reference to the accreditations HTML wrapper so the user doesn't have to keep scrolling down to get back to what they just edited in the accreditations area

Attachments (1)

Accreditation.py (13.3 KB) - added by Richard Lyders 3 years ago.
Append redirects with accreditation wrapper ID to keep user focused on the accreditation area after each change

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Richard Lyders

Attachment: Accreditation.py added

Append redirects with accreditation wrapper ID to keep user focused on the accreditation area after each change

comment:1 Changed 3 years ago by Richard Lyders

This enhancement can be closed as a duplicate of enhancement #13289 considering I've attached a complete unified patch to #13289 with this and all other changes I've implemented.

Complete patch attached with all changes to date ... (the attachment description erroneously calls it a "complete path".

Thanks again for this plugin. We are getting some good use out of it.

comment:2 Changed 3 years ago by Richard Lyders

Resolution: duplicate
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Cauly.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.