Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13325 closed defect (worksforme)

Style issue with custom fields

Reported by: ntmlod Owned by: Ryan J Ollos
Priority: normal Component: DynamicFieldsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I have created 2 customs field whose display is controlled by the milestone entry. The show/hide rule works as expected but the problem is that one field (select) is almost invisible because its width has been reduced to 4px in the <span> HTML tag just under <select>.

Disabling the plugin, the width is set to 99px at the same place. I made a test by changing the default value of the custom field from void to something but the width didn't change.
I looked at the HideRule section in rules.js but nothing really obvious to me.

Attachments (2)

With_Cmpnt_Hier.png (18.6 KB) - added by ntmlod 2 years ago.
Without_Cmpnt_Hier.png (21.9 KB) - added by ntmlod 2 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 2 years ago by Ryan J Ollos

Please share the relevant configuration from the ticket-custom section of trac.ini. I only need to see the part of ticket-custom for the two custom fields you mention.

comment:2 Changed 2 years ago by ntmlod

[ticket-custom]
task_comment = textarea
task_comment.cols = 60
task_comment.format = plain
task_comment.hide_when_milestone = |Documentation|Miscellaneous
task_comment.label = Comments
task_comment.options =
task_comment.order = 2
task_comment.rows = 5
task_comment.value =
task_status = select
task_status.hide_when_milestone = |Documentation|Miscellaneous
task_status.label = MP status
task_status.options = |Unknown|Ready|Postponed|Cancelled
task_status.order = 1
task_status.value =

comment:3 Changed 2 years ago by Ryan J Ollos

I cannot reproduce with Trac 1.0.1. It might be due to a plugin interaction, such as the patch in #13278. Can you show a screen capture of the issue?

comment:4 Changed 2 years ago by Ryan J Ollos

I don't see the issue even with ComponentHierarchy and patch from #13278. You may have to try disabling plugins until you find the plugin that conflicts.

Changed 2 years ago by ntmlod

Attachment: With_Cmpnt_Hier.png added

Changed 2 years ago by ntmlod

Attachment: Without_Cmpnt_Hier.png added

comment:5 Changed 2 years ago by ntmlod

With ComponentHierarchyPlugin
Without ComponentHierarchyPlugin

You already have pointed the issue here 7:ticket:13278

Well I should work on it by myself as it looks to only affects me in a particular session of my browser.

Last edited 2 years ago by ntmlod (previous) (diff)

comment:6 in reply to:  5 Changed 2 years ago by Ryan J Ollos

Replying to ntmlod:

... as it looks to only affects me in a particular session of my browser.

Have you done a hard refresh of the browser to refreshed cached assets?

comment:7 Changed 2 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

We can add additional changes in #13278, if needed.

comment:8 in reply to:  7 Changed 2 years ago by ntmlod

Replying to Ryan J Ollos:

Replying to ntmlod:

... as it looks to only affects me in a particular session of my browser.

Have you done a hard refresh of the browser to refreshed cached assets?

I have purged my "Admin" and "User" sessions but still no hierarchy.

Replying to Ryan J Ollos:

We can add additional changes in #13278, if needed.

I think there is no need to spend time on this at the moment. Our project can do without.
My laptop OS as well as my browsers are a bit outdated (Linux distro based on RHEL 6). It will be upgraded in the next weeks to an RHEL7 derivative.
I will check also with my colleagues how the component field looks like in their system (nearly all on Mac).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.