Modify

Opened 9 days ago

Closed 8 days ago

Last modified 8 days ago

#13344 closed defect (fixed)

Crash when submitting review

Reported by: ntmlod Owned by: jomae
Priority: normal Component: CodeReviewerPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

2017-12-07 14:06:22,928 Trac[main] ERROR: Exception caught while post-processing request:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 243, in dispatch
    self._post_process_request(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 340, in _post_process_request
    f.post_process_request(req, *(None,)*extra_arg_count)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 80, in post_process_request
    changeset = data['changeset']
TypeError: 'NoneType' object has no attribute '__getitem__'
2017-12-07 14:06:22,928 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 224, in dispatch
    self._post_process_request(req, *resp)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 338, in _post_process_request
    resp = f.post_process_request(req, *resp)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 90, in post_process_request
    self._update_tickets(changeset, review, status_changed)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 156, in _update_tickets
    changes = self._get_ticket_changes(tkt, status)
  File "build/bdist.linux-x86_64/egg/coderev/web_ui.py", line 204, in _get_ticket_changes
    field, value = group.split('=', 1)
ValueError: need more than 1 value to unpack

Attachments (0)

Change History (5)

comment:1 Changed 9 days ago by Jun Omae

In 17015:

CodeReviewerPlugin 1.0.0dev: fix post_process_request crashing when internal error is raised (refs #13344)

comment:2 Changed 9 days ago by Jun Omae

In 17016:

CodeReviewerPlugin 1.0.0dev: fix ValueError raising when configuration is invalid (refs #13344)

comment:3 Changed 9 days ago by Jun Omae

The original exception is leaded by invalid configuration (e.g. missing = in [codereviewer] passed).

Please close this ticket if the issue is gone with the latest version.

comment:4 Changed 8 days ago by ntmlod

Resolution: fixed
Status: newclosed

Yeah my trac.ini settings were wrong, anyway your fix was able to go through.

Thanks for the patch.

comment:5 Changed 8 days ago by Ryan J Ollos

Owner: set to jomae

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jomae.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.