Modify

Opened 20 months ago

Closed 3 weeks ago

#13377 closed defect (worksforme)

"FIXED_" prefix causing issue of Trac/GUI "Modify Ticket"

Reported by: johnt888@… Owned by: Olli Kallioinen
Priority: normal Component: MultiSelectFieldPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Just noticed the Trac/GUI will show/set both "FIXED_xxxx" & "xxxx" when we click "Modify Ticket" even the ticket only set "xxxx" to the field originally.

Attachments (0)

Change History (5)

comment:1 Changed 20 months ago by Olli Kallioinen

Are you sure it's a problem with the multi select plugin? The plugin is rather simple and I don't think it's adding such a prefix anywhere (although I haven't used trac or the plugin for a long time). Maybe some other plugin combined with multi select is causing the issue.

comment:2 Changed 20 months ago by anonymous

Yes, that's what I tested and you can put the following lines in trac.ini and verify it by youself:

test_two = text
test_two.format = list
test_two.label = ABC
test_two.multiselect = true
test_two.options = ABC100|FIXED_ABC100
test_two.order = 3
Last edited 20 months ago by Ryan J Ollos (previous) (diff)

comment:3 Changed 20 months ago by anonymous

Ok, I checked with more different cases. The issue is related to the name of options. Like the following cases, all have the issues:

test_two.options = ABC100|xxxx_ABC100

test_two.options = ABC100|ABC100_xxxx

The issue is the second option can't be same as the first option with "_" separator

If I changed the options to the following cases, and it's normal:

test_two.options = ABC100|xxxx_aBC100

test_two.options = ABC100|abc100_xxx
Last edited 20 months ago by Ryan J Ollos (previous) (diff)

comment:4 in reply to:  2 Changed 20 months ago by Ryan J Ollos

Replying to anonymous:

Yes, that's what I tested and you can put the following lines in trac.ini and verify it by youself:

I tried and cannot reproduce with Trac 1.0-stable and r17049 of this plugin.

  • Are you running the latest (r17049, 1.0.2dev)?
  • Do you have other plugins installed?
  • What do you mean by we click "Modify Ticket"? The only label Modify Ticket in the ticket view is the expander for the Change Properties section. Do you mean, submitting a ticket change for the test_two property with ABC100 selected will result in the ticket field changing to ABC100 FIXED_ABC100?
Last edited 20 months ago by Ryan J Ollos (previous) (diff)

comment:5 Changed 3 weeks ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Olli Kallioinen.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.