Modify

Opened 4 years ago

Closed 3 years ago

#13486 closed defect (duplicate)

Images don't work if the whole trac environment needs authentication

Reported by: Joachim Mairböck Owned by:
Priority: normal Component: TracWikiToPdfPlugin
Severity: normal Keywords: image httpauth
Cc: Trac Release: 1.2

Description

Embedded images cause WikiToPDFPlugin to fail if HTTP Authentication is needed to retrieve the image because it tries to read username and password from stdin (as it seems) and fails with "EOFError: EOF when reading a line".

Traceback:

Datei "/usr/lib/python2.7/dist-packages/trac/web/main.py", Zeile 613, in _dispatch_request
Datei "/usr/lib/python2.7/dist-packages/trac/web/main.py", Zeile 253, in dispatch
Datei "/usr/lib/python2.7/dist-packages/trac/wiki/web_ui.py", Zeile 190, in process_request
Datei "/usr/lib/python2.7/dist-packages/trac/mimeview/api.py", Zeile 1044, in send_converted
Datei "/usr/lib/python2.7/dist-packages/trac/mimeview/api.py", Zeile 721, in convert_content
Datei "build/bdist.linux-x86_64/egg/wikitopdf/wikitopdf.py", Zeile 264, in convert_content
Datei "build/bdist.linux-x86_64/egg/wikitopdf/wikitopdf.py", Zeile 103, in wiki_to_pdf
Datei "/usr/lib/python2.7/urllib.py", Zeile 98, in urlretrieve
Datei "/usr/lib/python2.7/urllib.py", Zeile 245, in retrieve
Datei "/usr/lib/python2.7/urllib.py", Zeile 213, in open
Datei "/usr/lib/python2.7/urllib.py", Zeile 457, in open_https
Datei "/usr/lib/python2.7/urllib.py", Zeile 377, in http_error
Datei "/usr/lib/python2.7/urllib.py", Zeile 704, in http_error_401
Datei "/usr/lib/python2.7/urllib.py", Zeile 781, in retry_https_basic_auth
Datei "/usr/lib/python2.7/urllib.py", Zeile 797, in get_user_passwd
Datei "/usr/lib/python2.7/urllib.py", Zeile 806, in prompt_user_passwd 

The plugin should use the existing trac user information to retrieve images and not try to fetch them with an independent request.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Ryan J Ollos

Owner: Diorgenes Felipe Grzesiuk deleted

comment:2 Changed 4 years ago by Ryan J Ollos

comment:3 Changed 3 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #5856.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.