Modify

Opened 4 months ago

Closed 4 months ago

#13535 closed defect (fixed)

AttributeError: type object 'Cell' has no attribute 'TYPE_STRING'

Reported by: Werner.Poschenrieder@… Owned by: Jun Omae
Priority: normal Component: ExcelDownloadPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description (last modified by Jun Omae)

when plugin is used in trac Python throws an exception then and trac reports:

Trac detected an internal error:
AttributeError: type object 'Cell' has no attribute 'TYPE_STRING'


The call stack is:
File "build/bdist.win32/egg/trac/web/main.py", line 647, in _dispatch_request
File "build/bdist.win32/egg/trac/web/main.py", line 258, in dispatch
File "build/bdist.win32/egg/trac/web/main.py", line 477, in _post_process_request
File "build/bdist.win32/egg/tracexceldownload/ticket.py", line 421, in post_process_request
File "build/bdist.win32/egg/tracexceldownload/ticket.py", line 464, in _convert_report
File "build/bdist.win32/egg/tracexceldownload/api.py", line 368, in set_col_widths

..
367 from openpyxl.cell import Cell
368 TYPE_STRING = Cell.TYPE_STRING
..

Local Variables

Name Value
Cell     <class 'openpyxl.cell.cell.Cell'>

I am absolutely new to Python however I may confirm that cell.py in my installation has an attribute TYPE_STRING = 's'.

The trac installation is from Bitnami. openpyxl has been installed by easy_install

System Information
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) 

Package   Version
Trac      1.2.3
Babel     0.9.6
Genshi    0.6 (without speedups)
GIT       2.19.1.windows.1
mod_wsgi  3.5 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite  2.6.3
Python    2.7.15 (v2.7.15:ca079a3ea3, Apr 30 2018, 16:22:17) [MSC v.1500 32 bit (Intel)]
setuptools 20.9.0
SQLite    3.7.6.2
jQuery    1.11.3
jQuery UI 1.11.4
jQuery Timepicker 1.5.5

Attachments (0)

Change History (2)

comment:1 Changed 4 months ago by Jun Omae

Description: modified (diff)
Status: newaccepted

The root cause is that the TYPE_STRING has been removed in openpyxl / commit / b733e47647b3.

Work around is to downgrade openpyxl 2.5.x:

$ easy_install -U 'openpyxl==2.5.14'

comment:2 Changed 4 months ago by Jun Omae

Resolution: fixed
Status: acceptedclosed

In 17343:

ExcelDownloadPlugin: compatibility fix with openpyxl 2.6 (closes #13535)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.