Modify

Opened 16 months ago

Closed 16 months ago

Last modified 15 months ago

#13573 closed defect (fixed)

Seeing Warning: Error with navigation contributor "PreferencesModule" in browser

Reported by: Adrian Heath Owned by: Ryan J Ollos
Priority: normal Component: DynamicFieldsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description (last modified by Jun Omae)

Upgraded from Trac 0.12/python 2.6 to Trac 1.2.3/python 2.7.

When building and installing DynamicFields from trunk, seeing following message in browser:-

Warning: Error with navigation contributor "PreferencesModule"

trac.log reporting

2019-07-12 10:56:31,871 Trac[chrome] ERROR: Error with navigation contributor PreferencesModule:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/trac/web/chrome.py", line 826, in prepare_request
    contributor.get_navigation_items(req) or []:
  File "/usr/lib/python2.7/dist-packages/trac/prefs/web_ui.py", line 48, in get_navigation_items
    panels = self._get_panels(req)[0]
  File "/usr/lib/python2.7/dist-packages/trac/prefs/web_ui.py", line 138, in _get_panels
    p = list(provider.get_preference_panels(req) or [])
  File "build/bdist.linux-x86_64/egg/dynfields/web_ui.py", line 61, in get_preference_panels
    if self._get_prefs_data(req):  # only show if there are preferences
  File "build/bdist.linux-x86_64/egg/dynfields/web_ui.py", line 101, in _get_prefs_data
    rule.update_pref(req, trigger, target, key, opts, pref)
  File "build/bdist.linux-x86_64/egg/dynfields/rules.py", line 330, in update_pref
    trigval = spec['trigger_value'].replace('|', _(" or "))
UnboundLocalError: local variable '_' referenced before assignment

Attachments (0)

Change History (5)

comment:1 Changed 16 months ago by Jun Omae

Description: modified (diff)

comment:2 Changed 16 months ago by Ryan J Ollos

Looks like a regression in r13689.

comment:3 Changed 16 months ago by Ryan J Ollos

In 17416:

TracDynamicFields 2.3.0dev: Fix regression in r13689.

Refs #13573.

comment:4 Changed 16 months ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

comment:5 Changed 15 months ago by Adrian Heath

Thank you for your timely update.

That was the only issue we had upgrading Trac + plugins from v0.12 to v1.2.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.