Modify

Opened 3 years ago

#13599 new defect

Unable to install due to ConfigurationError

Reported by: anonymous Owned by: ejucovy
Priority: normal Component: MultiRepoSearchPlugin
Severity: major Keywords: installation repository search
Cc: Trac Release: 1.3

Description

I've installed the latest version (0.6) of MultiRepoSearchPlugin on Trac 1.3. That didn't work due to API changes in 1.3. I think I've solved most of these issues, they weren't very difficult to fix. But now I've come upon a problem that I can't figure out.

The documentation says to

trac-admin . multireposearch reindex_all

Which gives this error

ConfigurationError: Cannot find an implementation of the <code>IMultiRepoSearchBackend</code> interface named <code>SqlIndexer</code>. Please check that the Component is enabled or update the option <code>[multireposearch] search_backend</code> in trac.ini.

SqlIndexer is part of this plugin, so I can't understand why it says it's not enabled. Gut feeling is this is also due to some API changes, but I can't figure out what's wrong.

Here's the component section from my trac.ini:

[components]
multireposearch.* = enabled

I don't have a [multireposearch] section in the trac.ini, and from reading the source I don't think I actually need to have one?

I'm really struggling here, so I would appreciate any help you can provide.

(Not sure if it's relevant, but I've obviously also installed TracSqlHelperScript, as dictated by the requirements, and tried both 1.2 and 0.12 with no changes regarding the error above. And I'm using MySQL as backend.)

Attachments (0)

Change History (0)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain ejucovy.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.