Modify

Opened 11 years ago

Closed 10 years ago

#1386 closed defect (fixed)

Blocked tickets showing as text not link

Reported by: paresh.solanki@… Owned by: Noah Kantrowitz
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords: needinfo
Cc: paresh.solanki@…, xurizaemon@… Trac Release: 0.10

Description

This may be a config issue, but I have checked my Trac.ini and all settings appear correct

When I put a ticket number into the blocking field and submit the change, in the summary box, the numbers in the blocked by and blocking fields are being shown as simple numbers, and not as links.

Also, the ticket that is being blocked is allowed to be resolved. This did work when I first installed it, but I have since added a few other plugins and I'm not sure when it stopped working.

Any help please?

Attachments (4)

trac.log (9.4 KB) - added by paresh.solanki@… 11 years ago.
Trac Log File
tracDel.log (5.2 KB) - added by paresh.solanki@… 10 years ago.
Without TicketDelete
tracDel.2.log (5.2 KB) - added by paresh.solanki@… 10 years ago.
With TicketDelete
trac_noDel.log (5.2 KB) - added by paresh.solanki@… 10 years ago.
Without TicketDelete

Download all attachments as: .zip

Change History (14)

comment:1 Changed 11 years ago by Noah Kantrowitz

Component: TracHacksMasterTicketsPlugin
Owner: changed from Alec Thomas to Noah Kantrowitz

Check that all the JavaScript files on the page are loading. Some plugins (notably the TinyMCE plugin) are broken and will prevent other plugins from loading content.

Changed 11 years ago by paresh.solanki@…

Attachment: trac.log added

Trac Log File

comment:2 Changed 11 years ago by paresh.solanki@…

Sorry but can you explain how to do that? Are there any particular files I should be looking out for?

I don't have much experience with Javascript or python, so I will need guidance here

TinyMCE is not loaded.

I have attached a trac.log file in case it helps.

comment:3 in reply to:  2 Changed 11 years ago by xurizaemon

Cc: paresh.solanki@… added; anonymous removed

Replying to Paresh.Solanki@BellFruitGames.co.uk:

Sorry but can you explain how to do that?

You can check if there's any error reported in your browser's error console, which varies from browser to browser. In Firefox, the FireBug extension is excellent, or without it you can use the "Error Console" under the Tools menu. In Explorer you should get a yellow warning icon in bottom left corner (hopefully).

comment:4 Changed 11 years ago by xurizaemon

Cc: xurizaemon@… added

Paresh, looking at your Trac log, I would suggest disabling the BatchMod plugin in the first instance to see if this helps. It appears to not be able to find the HTDOCS directory.

comment:5 Changed 10 years ago by paresh.solanki@…

It didn't make any difference.

I have only got error messages such as this in the browser Warning: Error in parsing value for property 'display'. Declaration dropped. Source File: http://localhost:8000/GameCore/chrome/common/css/trac.css Line: 66

Disabling BatchMod (then restarting tracd server) has not had any effect.

comment:6 Changed 10 years ago by paresh.solanki@…

It looks like it is a conflict with the BatchMod module.

I did a fresh re-install of the system and checked Master Tickets after each stage and it broke after the BatchMod module was installed.

The problem is that uninstalling the BatchMod module does not fix the master tickets, so I'll have to start a clean install again :(

comment:7 Changed 10 years ago by paresh.solanki@…

Further update.

It is not only BatchMod (batchmodify 0.1.0), but also TicketDelete (tracticketdelete 1.1.4) that's causing the problem.

To replicate:- Start with a system that has a working MasterTicket module. Install TicketDelete and restart the Trac server (tracd in my case) view a ticket that is blocking and the blocked tickets are shown as text Disable TicketDelete and restart and all is good again.

It's possible that there are others that I haven't tried yet.

comment:8 Changed 10 years ago by Noah Kantrowitz

Keywords: needinfo added

Please post a copy of your log with TicketDelete enabled. I should not be doing that.

Changed 10 years ago by paresh.solanki@…

Attachment: tracDel.log added

Without TicketDelete

Changed 10 years ago by paresh.solanki@…

Attachment: tracDel.2.log added

With TicketDelete

Changed 10 years ago by paresh.solanki@…

Attachment: trac_noDel.log added

Without TicketDelete

comment:9 Changed 10 years ago by paresh.solanki@…

Log was set to DEBUG Two log files, TracnoDel.log is the log with TicketDel disabled, TracDel.log is the log with TicketDel enabled.

Please ignore tracDel.2.log

comment:10 Changed 10 years ago by Noah Kantrowitz

Resolution: fixed
Status: newclosed

The new version does the linkification using a stream filter, and therefore isn't subject to the problems of JavaScript.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.