Modify

Opened 3 months ago

Closed 6 weeks ago

Last modified 6 weeks ago

#13881 closed defect (duplicate)

NoneType' object has no attribute 'setdefault

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

Trac 1.5.1 windows env + TracAccountManager-0.6.dev0

pip install https://trac-hacks.org/browser/accountmanagerplugin/trunk?format=zip

Conf:

acct_mgr.admin.* = enabled
acct_mgr.api.* = enabled
acct_mgr.db.sessionstore = disabled
acct_mgr.htfile.htdigeststore = disabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.http.* = disabled
acct_mgr.notification.* = disabled
acct_mgr.pwhash.* = disabled
acct_mgr.register.* = enabled
acct_mgr.svnserve.svnservepasswordstore = disabled
acct_mgr.web_ui.* = enabled
acct_mgr.web_ui.resetpwstore = disabled
trac.web.auth.loginmodule = enabled
acct_mgr.register.* = disabled

Error happens when i select users in left menu:

AttributeError: 'NoneType' object has no attribute 'setdefault'

Log:

2020-09-09 14:43:30,223 Trac[main] ERROR: [::1] Internal Server Error: <RequestWithSession "GET '/admin/accounts/users'">, referrer 'http://localhost/trac/timefiler/admin/general/plugin'
Traceback (most recent call last):
  File "build\bdist.win-amd64\egg\trac\web\main.py", line 612, in dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win-amd64\egg\trac\web\main.py", line 264, in dispatch
    metadata.setdefault('iterable', chrome.use_chunked_encoding)
AttributeError: 'NoneType' object has no attribute 'setdefault'

Attachments (0)

Change History (2)

comment:1 Changed 6 weeks ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #13720.

comment:2 Changed 6 weeks ago by Ryan J Ollos

In 17867:

TracAccountManager 0.6dev: Trac 1.5dev is not yet supported

Refs #13720, #13881.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.