Modify

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#14049 closed defect (duplicate)

Problem to login with a new user

Reported by: haraldlesch Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.4

Description

If i create a new user with the plugin and i try to login i always get auto logged in with my previous user i have logged in before. The login popup where you can enter username / password gets never shown again. In the log i see that it seems to keep the session ids even i clicked logout and when i login again it just uses this session / user. How to fix this behaviour so i can see the login popup again. Before installing the plugin, the login popup got shown after i click on login. After installing the plugin i get always auto logged in, even when i disable the plugin it still auto logges me in.

Attachments (0)

Change History (4)

comment:1 Changed 9 months ago by haraldlesch

Severity: normalmajor

comment:2 Changed 9 months ago by Jun Omae

Keywords: Login removed
Priority: highnormal
Severity: majornormal

That is typically a installation and/or configuration issue. Please ask on the trac-users mailing list for support questions.

comment:3 Changed 9 months ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #4127.

comment:4 in reply to:  1 Changed 9 months ago by anonymous

Replying to haraldlesch:

I got a solution by using TracAccountManager 0.6.dev0 and using the plugin's LoginModule

[components]
acct_mgr.web_ui.LoginModule = enabled
trac.web.auth.LoginModule = disabled
Last edited 9 months ago by Ryan J Ollos (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.