Modify

Opened 10 months ago

Closed 10 months ago

Last modified 9 months ago

#14075 closed defect (worksforme)

Mixed url path in e-mails (randoms) in notifications

Reported by: anonymous Owned by: Jun Omae
Priority: normal Component: TracHtmlNotificationPlugin
Severity: major Keywords:
Cc: Trac Release: 1.4

Description

Mixed url path in e-mails (randoms) in notifications loks like this

http://mysuperdomain.com/pydoc/timeline?from=2021-10-25T22%3A36%3A42%2B02%3A00&precision=second
http://mysuperdomain.com/pydoc/query?status=!closed&type=task
http://mysuperdomain.com/pydoc/query?status=!closed&reporter=admin
http://mysuperdomain.com/pydoc/query?status=!closed&priority=major
http://mysuperdomain.com/pydoc/ticket/2?action=diff&version=1
http://mysuperdomain.com/pydoc/milestone/milestone1
http://mysuperdomain.com/pydoc/ticket/2#comment:6
http://mysuperdomain.com/pydoc/query?status=!closed&cc=~admin

Last was instaled pydoc but disabled due errors. But pydoc is changed to wiki. Also can be browser, and on this is s http://mysuperdomain.com/browser as wiki msg Welcome to Trac and can be any of this url, and after try create ticker is included in e-mail.

Using FCGI, SimpleMultipleProject and looks it's problem around.

Attachments (0)

Change History (7)

comment:1 Changed 10 months ago by anonymous

#8597 Looks similar

Last edited 10 months ago by Jun Omae (previous) (diff)

comment:2 Changed 10 months ago by Jun Omae

Priority: highestnormal
Resolution: wontfix
Status: newclosed

That is due to incorrect [project] url option. Configure correct URL for your TracEnv.

comment:3 Changed 10 months ago by Jun Omae

If the issue is still existent after disabling SimpleMultipleProjectPlugin, reopen it.

comment:4 Changed 10 months ago by Jun Omae

Resolution: wontfixworksforme

comment:5 Changed 9 months ago by anonymous

After provide url as domain notifications is ok now, but whole trac can work at anny path like on 1st post. Also it's problem in SimpleMultipleProjectPlugin some configuration or trac? Eg.

http://trac-domain.com/chrome/common/js/search.js is 404 and other files that site is broken, but when provide http://trac-domain.com/x then search.js and other css etc. is loaded corectly.

Then eg. have url from noticiation:

http://trac-domain.com/timeline?from=2021-10-27T00%3A21%3A40%2B02%3A00&precision=second And website showing content ok, but when going to New ticket have url

http://trac-domain.com/timeline/newticket but I expecting:

http://trac-domain.com/newticket - without timeline/

comment:6 Changed 9 months ago by anonymous

my url is:

base_url == http://trac-domain.com

comment:7 in reply to:  5 Changed 9 months ago by Jun Omae

Sorry for my wrong comment. Try to configure [trac] base_url option rather than [project] url option.

After provide url as domain notifications is ok now, but whole trac can work at anny path like on 1st post. Also it's problem in SimpleMultipleProjectPlugin some configuration or trac?

That is a SimpleMultipleProjectPlugin issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.