Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1594 closed defect (wontfix)

IE 7 does not recognize mime type when Rev Tree clicked

Reported by: anonymous Owned by: Emmanuel Blot
Priority: normal Component: RevtreePlugin
Severity: critical Keywords:
Cc: Trac Release: 0.10

Description

IE 7 does not recognize mime type when Rev Tree clicked. However, under Firefox it's working correctly. I am attaching a screen-shot to describe the problem better.

-dt

Attachments (1)

ScreenShot144.png (20.0 KB) - added by anonymous 10 years ago.
Print screen of the error message.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by anonymous

Attachment: ScreenShot144.png added

Print screen of the error message.

comment:1 Changed 10 years ago by anonymous

looking into this mime type more, I found out that RevTree returns 'application/xhtml+xml;charset=utf-8' which according to this: http://blogs.msdn.com/ie/archive/2005/09/15/467901.aspx IE does not support.

-dt

comment:2 Changed 10 years ago by anonymous

Here is how this problem could be fixed at apache level.

http://www.ibm.com/developerworks/library/x-tipapachexhtml/index.html

comment:3 Changed 10 years ago by Emmanuel Blot

Resolution: wontfix
Status: newclosed

As documented in the RevtreePlugin page, IE (6, 7, ...) browsers are not supported and won't. RevtreePlugin may work with IE some days (who knows...), but it won't be supported.

I just don't want to spent time supporting such a buggy browser, and I don't want to trash the code just to meet M$ non-standard web requirements ;-)

Trac already sports workarounds for the sake of IE compliance, whereas other browsers work fine without this mess. I won't do the same for this plugin. Sorry IE users, you'll have to switch to a real browser or not to use the plugin.

application/xhtml+xml is the proper mime type to use: the generated code is pure XML, and text/html is an invalid type for the generated code: RevtreePlugin do not generate HTML, but XHTML strict with embedded SVG.

Last time I tried embedded SVG w/ IE 7, it failed to render the page anyway.

comment:4 Changed 10 years ago by anonymous

The problem is that a lot of us in locked down corporate environments are stuck using IE... I would love to use this plugin, but it doesn't sound like we'll ever be able to :(

comment:5 in reply to:  4 Changed 10 years ago by Emmanuel Blot

Replying to anonymous:

The problem is that a lot of us in locked down corporate environments are stuck using IE... I would love to use this plugin, but it doesn't sound like we'll ever be able to :(

Time to convince your boss that IE is not a reliable web browser and that it does not support W3C standards ;-) If they do not like open source software, maybe they are ok w/ Opera?

I don't think RevtreePlugin will ever work with IE, and I don't think IE will ever work properly.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.