Modify

Opened 10 years ago

Closed 8 years ago

#1718 closed defect (duplicate)

'dictionary key must be string' while executing 'ticket.get()'

Reported by: Georg-W. Koltermann Owned by: Alec Thomas
Priority: normal Component: XmlRpcPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description (last modified by Odd Simon Simonsen)

The above error message pops up for about half of my track tickets when accessing them in Eclipse 3.3 via Mylin. The other half of my tickets can be accessed ok. The Trac repository is being accessed via the xmlrpc plugin that I just installed.

There doesn't seem to be a httpd logfile entry about it, just the popup error box in Eclipse Mylin.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Steffen Pingel

Description: modified (diff)

Does your repository use custom fields? See #871 for a related bug report.

comment:2 in reply to:  1 Changed 9 years ago by anonymous

Replying to stp:

Does your repository use custom fields? See #871 for a related bug report.

Yes you are right that was the problem. The patch from #871 fixe my issue.

Thanks a lot!

Maybe you want to add the patch to the XmlRpcPlugin zip file?

-- Regards, Georg.

comment:3 Changed 8 years ago by Odd Simon Simonsen

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Closing as duplicate of #871.

Modify Ticket

Action
as closed The owner will remain Alec Thomas.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.