Modify

Opened 10 years ago

Closed 9 years ago

#1739 closed defect (worksforme)

Tags and blog in conflict?

Reported by: anonymous Owned by: John Hampton
Priority: normal Component: TracBlogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Blog seems to be working fine, but this error message was received. Unfortunately not by me, so the last line was truncated - but is this enough to work on?

Trac .10.4, blog, webadmin and tags are all from svn. Debian Etch OS.

Traceback (most recent call last):
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/var/lib/python-support/python2.4/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/tBlog/new_blog.py", line 108, in process_request
  File "build/bdist.linux-x86_64/egg/tBlog/new_blog.py", line 162, in _new_blog_post
  File "build/bdist.linux-x86_64/egg/tractags/api.py", line 160, in add_tags
  File "/var/lib/python-support/python2.4/trac/db/util.py", line 50, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/var/lib/python-support/python2.4/trac/db/sqlite_backend.py", line 56, in execute
    args or [])
  File "/var/lib/python-support/python2.4/trac/db/sqlite_backend.py", line 48, in _rollback_on_error
    return function(self, *args, **kwargs)
IntegrityError: columns tagspace, name, tag are not

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Lachlan Musicman

That was reported by me - I thought I would let you know so that we could converse regards fixing the problem :)

comment:2 in reply to:  1 Changed 10 years ago by John Hampton

Status: newassigned

Replying to datakid:

That was reported by me - I thought I would let you know so that we could converse regards fixing the problem :)

Do you have the end of the traceback? My guess is that it says that it's not unique, but I'd be interested in finding out.

Also, any steps to reproduce the error? Tags shouldn't be in conflict with Blog. In fact, Blog relies on tags. So, if you can give me a bit more info, I'll see if I can duplicate the issue and track it down

comment:3 Changed 10 years ago by Lachlan Musicman

Sure, sorry about the brief brief.

Details:

Brand new install. Finished on Wednesday, blog post made on Thursday. It was the first post made to the blog (could this be an issue?), and the error occurred when the submit changes button was pressed.

Also, apart from getting that error, note that the blog is working as expected - ie, it's seemingly non critical error :) http://plumi.org is where you can see it.

I can't reproduce it :). I just tried posting something new to the blog (I have since deleted teh test post) but I've not been able to reproduce. Potentially it is something to do with putting something into an otherwise empty db/blank blog?

comment:4 Changed 9 years ago by John Hampton

Resolution: worksforme
Status: assignedclosed

Can't reproduce error and it appears that http://plumi.org is running WordPress now.

Closing as worksforme. If anyone can reproduce it, then they can reopen the ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain John Hampton.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.